mod_perl 1.99_5 says "cannot use threaded MPM without ithreads enabled Perl"

mod_perl 1.99_5 says "cannot use threaded MPM without ithreads enabled Perl"

Post by RAYtracer__ DREAMWALK » Thu, 05 Sep 2002 01:21:59



hi

i have mod_perl 1.99_5, apache 2.0.40, Perl 5.80 (compiled with ithreads)
but mod_perl 1.99_5 says:
"cannot use threaded MPM without ithreads enabled Perl" when i put
    LoadModule perl_module modules/mod_perl.so
into httpd.conf... why?

thanx
bye

 
 
 

mod_perl 1.99_5 says "cannot use threaded MPM without ithreads enabled Perl"

Post by Rich Bowe » Fri, 06 Sep 2002 11:10:07


On 3 Sep 2002 09:21:59 -0700, RAYtracer__

Quote:> hi

> i have mod_perl 1.99_5, apache 2.0.40, Perl 5.80 (compiled with ithreads)
> but mod_perl 1.99_5 says:
> "cannot use threaded MPM without ithreads enabled Perl" when i put
>     LoadModule perl_module modules/mod_perl.so
> into httpd.conf... why?

Because a threaded Apache/mod_perl needs a threaded Perl.

--

Cooper McGregor - Apache training
coopermcgregor.com/training

 
 
 

mod_perl 1.99_5 says "cannot use threaded MPM without ithreads enabled Perl"

Post by RAYtracer__ DREAMWALK » Sat, 07 Sep 2002 22:48:48



> On 3 Sep 2002 09:21:59 -0700, RAYtracer__

> > hi

> > i have mod_perl 1.99_5, apache 2.0.40, Perl 5.80 (compiled with ithreads)
> > but mod_perl 1.99_5 says:
> > "cannot use threaded MPM without ithreads enabled Perl" when i put
> >     LoadModule perl_module modules/mod_perl.so
> > into httpd.conf... why?

> Because a threaded Apache/mod_perl needs a threaded Perl.

i have Perl 5.80 compiled with ithreads. it this not the same?
...and apache is compiled with worker mpm...