apache 1.3.26 problem

apache 1.3.26 problem

Post by Mathias Koerbe » Thu, 20 Jun 2002 18:43:32



I just ran into a problem with the new Apache 1.3.26.

Accessing some pages on Ebay (specifically the 'MyEbay' link which will
result in a sign-in page) through an Apache-based proxy resulted in those
pages showing up as HTML Source text in both Opera 6.01 Linux and Konqueror
2.2.2.

With Apache 1.3.22 with the exact same configuration, there is no
problem...

from my request_log:
noisy.koerber.org 172.22.22.252 -> 172.22.22.1 80 HTTP/1.0 - -
[19/Jun/2002:17:31:45 +0800] "GET
http://cgi3.ebay.com/aw-cgi/eBayISAPI.dll?SignIn&UsingSSL=0&pUserId=&...
HTTP/1.0" 200 14442 [-]

When Apache 1.3.26 isused as proxy, the following will be logged in
error_log, and the page will show up mangled:

[Wed Jun 19 17:20:58 2002] [warn] proxy: Ignoring duplicate HTTP status line returned by buggy server
http://cgi1.ebay.com/aw-cgi/eBayISAPI.dll?MyEbayLogin (GET)
[Wed Jun 19 17:20:58 2002] [warn] proxy: Ignoring duplicate HTTP status line returned
by buggy server http://cgi3.ebay.com/aw-cgi/eBayISAPI.dll?SignIn&UsingSSL=0&pUserId=&... (GET)

Here is the config.status file that was used to recompile both versions of
Apache afresh with:

#!/bin/sh
##
##  config.status -- APACI auto-generated configuration restore script ##
##  Use this shell script to re-run the APACI configure script for ##
restoring your configuration. Additional parameters can be supplied. ##

./configure \
"--with-layout=Apache" \
"--enable-module=info" \
"--enable-module=auth_dbm" \
"--enable-module=proxy" \
"--enable-module=expires" \
"--enable-module=rewrite" \
"--enable-module=unique_id" \
"--enable-module=log_referer" \
"--enable-module=log_agent" \
"--enable-module=log_config" \
"--enable-module=so" \

Does anyone have a fix for this?
thanks

 
 
 

apache 1.3.26 problem

Post by Klaus Johannes Rusc » Thu, 20 Jun 2002 20:02:56



> I just ran into a problem with the new Apache 1.3.26.

> Accessing some pages on Ebay (specifically the 'MyEbay' link which will
> result in a sign-in page) through an Apache-based proxy resulted in those
> pages showing up as HTML Source text in both Opera 6.01 Linux and Konqueror
> 2.2.2.

Looks like a problem with the Ebay site, the response from the server is

HTTP/1.1 200 OK
Server: Microsoft-IIS/4.0
Date: Wed, 19 Jun 2002 11:00:54 GMT
Connection: close
Set-Cookie:
s=AQAAAAEAAAASAAAAPAAAAGZkED3mnhk9QDIwOS42OC4yLjMzZTF0ZXN0Q29va2llIC
QyJCQyZ1NNQUdxTDNob3ZUSXoxa0NUYloxAA**j; path=/; domain=.ebay.com
HTTP/1.1 200 OK
Server: Microsoft-IIS/4.0
Date: Wed, 19 Jun 2002 11:00:54 GMT
Connection: close

Note the duplicate HTTP headers and the lack of a Content-Type header.

--
Klaus Johannes Rusch

http://www.atmedia.net/KlausRusch/

 
 
 

apache 1.3.26 problem

Post by Mathias Koerbe » Thu, 20 Jun 2002 20:35:14


Quote:> Looks like a problem with the Ebay site, the response from the server is

That was my first thought, (and still may be true), though 1.3.22 seems
to be immune to this problem and I can browse those pages fine
(maybe 1.3.26 got too picky?).
Mail to ebay is out, though I'm not sure whether they'll listen.

mk

 
 
 

1. Apache apache 1.3.26 config file

I recently deinstalled apache 2.0 and installed 1.3.26
(apache+mod_ssl-1.3.26+2.8.10) on my FreeBSD box after realising that I
couldn't get Gallery to work on apache 2 as yet. However, I now seem to have
a problem with the config file. Can anyone give me a pointer - I just can't
see what's going wrong.

When I run the apache config test I get:
    > apachectl configtest
    default_listeners(): getaddrinfo(PASSIVE) for family 28: No address
associated with hostname

Where am I going wrong!?!

Many thaks,
rob

2. testparm hangs

3. Problems with Apache 1.3.26 build on Solaris 7 (and Websphere integration)

4. Driver for Adaptec 2940

5. apache 1.3.26 + PHP 4.2.1 problem

6. Problem with svrmgr during installing Oracle on Linux (SUSE6.1)

7. ErrorDocument problems Apache 1.3.26

8. bash script - getting filesize

9. Apache 1.3.26 authorization problem

10. Apache 1.3.26 in RedHat 7.2 - Problem with pthread

11. Proxy problems with Apache 1.3.26 - broken images

12. apache 1.3.26 + php 4.2.1 problems

13. !!Apache 1.3.26 CGI problem on OpenBSD -- HELP!!!