Delete/BackSpace not working in openwin?

Delete/BackSpace not working in openwin?

Post by Richard Q. Ch » Tue, 18 Jul 1995 04:00:00



Hi,
        I am using the latest binary Mosaic on a sparc 10
running SunOS 4.1.3, openwindow 3.0. The problem is that the
delete/backspace keys do not work, when prompted for saving files,
entering searching words, etc. The faq mentions the XKeysymDB.txt
be put in /usr/lib/X11. We do not have this directory but we do already
have XKeysymDB in /usr/openwin/lib. By replacing that file with the
one suggested by the faq, and by putting the lines

 *XmText.translations: #override\n\
<Key>osfDelete: delete-previous-character()
*XmTextField.translations: #override\n\
 <Key>osfDelete: delete-previous-character()

in my ~/.Xdefaults followed by xrdb ~/.Xdefaults, and by defining

setenv XKEYSYMDB /usr/openwin/lib/XKeysymDB

I still could not get the Delete/Backspace keys working! Does anyone
have similar configuration and similar problems? How can this
be fixed? One will really appreciate these keys only if one has worked
without them!

Thanks for any help.

Richard

--
Richard Q. Chen

 
 
 

Delete/BackSpace not working in openwin?

Post by Rick Ba » Wed, 19 Jul 1995 04:00:00



says...
Quote:

>Hi,
>        I am using the latest binary Mosaic on a sparc 10
>running SunOS 4.1.3, openwindow 3.0. The problem is that the
>delete/backspace keys do not work, ...

...

I ran into the same problem installing an older version of Mosaic
on my SUNOS 4.1.3 Sparc2.  I solved it by physically creating the
directory /usr/lib/X11 and placing the XKeysymDB file in that directory.
That is the only way I was able to solve the problem.

Hope This Helps!

- Rick Barr
  CIS Repository Services
  Electronic Data Systems