No Login Script / Alias problems on Remote Host

No Login Script / Alias problems on Remote Host

Post by Robert Katt » Sun, 28 Oct 2001 05:15:11



My Hosting company, "webhosting.com",
does not support a login script.  

The default shell is "csh", running  SunOS 5.7

I am trying to configure the environment with a script file to use
some basic features, such as, history, prompt, setprompt, alias, etc.

My little executable file runs but hiccups and shows an error when I
try to set up an alias.  Here is the code and the error:

alias setprompt 'set prompt="${cwd} > "'

setprompt: alias not found
/usr/bin/alias[8]: set prompt="${cwd} > ": invalid alias name

~~~~
Suggestions welcome - TIA.

-R

 
 
 

No Login Script / Alias problems on Remote Host

Post by Barry Margoli » Sun, 28 Oct 2001 06:51:40




>My Hosting company, "webhosting.com",
>does not support a login script.  

>The default shell is "csh", running  SunOS 5.7

Very strange.  I thought running .cshrc and .login was standard for csh.

Quote:

>I am trying to configure the environment with a script file to use
>some basic features, such as, history, prompt, setprompt, alias, etc.

>My little executable file runs but hiccups and shows an error when I
>try to set up an alias.  Here is the code and the error:

>alias setprompt 'set prompt="${cwd} > "'

>setprompt: alias not found
>/usr/bin/alias[8]: set prompt="${cwd} > ": invalid alias name

To execute a script in the context of the current shell, you have to use
"source scriptname".  It looks like you're trying to run the script as a
command, and it's being run by ksh rather than csh.

--

Genuity, Woburn, MA
*** DON'T SEND TECHNICAL QUESTIONS DIRECTLY TO ME, post them to newsgroups.
Please DON'T copy followups to me -- I'll assume it wasn't posted to the group.

 
 
 

1. script alias problem - Re: apache alias and script alias problem

I actually did not have the <Directory> setup properly.

I am still having a problem with the script alias.

For example.

I set an alias -

Alias / /home/user1/html/

and a Script Alias -
ScriptAlias /cgi-bin/ /home/user/cgi-bin/

However the script alias is not working because the log shows that
when entering:
http://localhost/cgi-bin/

/home/user/html/cgi-bin/ is actually being referenced.

When I remove the first Alias statement the cgi-bin script directory
is properly aliased.

Any suggestions.

Thanks.

---
Andrew

Please remove TOREMOVE chars to e-mail me

2. DSL + Dynamic IP

3. Clarifying problem to login to remote host and execute script

4. EXPLAIN THE MYSTERIOUS OPEN FILE DESCRIPTOR

5. Script To Automatically Login To Remote Host

6. Routing and LRP

7. apache alias and script alias problem

8. Horizontal greyish lines

9. Problem dumping remote host (linux) to SCO host

10. alias created in csh script to remain in login shell

11. Tcpd logging of user@host from remote login/telnet/ftps

12. Determining remote login host?

13. TCPD Logging of user@host rom remote telnet and ftp logins