tab problem

tab problem

Post by Zachary Blacksto » Thu, 05 Dec 1996 04:00:00



Hello,

I was writing a shell script, editting it in pico, and for some reason
when i tryed to enter a tab into a sed command i was running, it would not
recognize it.

ex:

sed '/  /d' <filename>

for some reason whenever I enter a tab between the /   /  it comes up as
only a few spaces.  Now, I'm not sure that the size of the whitespace is
whats wrong, but it doesn't recognize the tab when it searches the file.
I also tryed inserting a tab from pico, ^I, but that didn't work either.
Could it be the editor I'm using or another problem.  any suggestion would
be helpful.

I also found that it worked fine with the tab on the command line.

thanks in advance,
infrared

 
 
 

tab problem

Post by Dave Bro » Thu, 05 Dec 1996 04:00:00



: I was writing a shell script, editting it in pico,

For God's sake, use a real editor--i.e. pretty much *anything* but pico.

: and for some reason
: when i tryed to enter a tab into a sed command i was running, it would not
: recognize it.

That's because pico expands tabs.  Don't use pico.  It's broken.  It
should have never been released for anything.  It's a piece of crap.
Mere words cannot begin to express my contempt for pico.

Scariest thing I ever saw a sysadmin type: 'pico sendmail.cf'.  Don't
use pico.

Maybe I should write a "Pine and pico considered harmful" FAQ.

: Could it be the editor I'm using or another problem.  

Yes, it could.

Find some other editor.  Use that instead.

Since you're used to Pico's keystrokes by now (*sigh*) I'd recommend
some Emacs clone or other.  If you're feeling brave you could use actual
Emacs, but your sysadmin would be at best marginally happier, and
probably considerably more upset.

: I also found that it worked fine with the tab on the command line.

That's because the command line doesn't use pico.

--Dave
--
http://www.csclub.uwaterloo.ca/~dagbrown/

 
 
 

1. mysifying Alt+Tab problem

I just installed KDE 3.0.3 on my IBM Thinkpad.  I'm running Debian
3.0r0.  When I use Alt+Tab it just cycles back and forth between the
top two windows, even if I have more than two windows on the screen.
How can I make it pop up that little window with an icon for each
running window?

My settings:
Look & Feel -> Window Behavior -> Focus -> Focus policy: Focus follows
mouse
Look & Feel -> Window Behavior -> Focus -> Keyboard: KDE, Traverse
windows on all desktops checked
Look & Feel -> Shortcuts -> Global Shortcuts -> Walk Through Windows:
Alt+Tab

Thanks,
Benjamin

2. 2.5.12 drivers/ide/pdcadma.c

3. Annoying TABs problem

4. boot disk3

5. fvwm95 - ALT+TAB problems switching windows.

6. 2.2.0pre7 boot error from hell

7. Script GURUs - a tab is a tab is a tab

8. YELLOWDOG on G3

9. entering tab in vi without using tab key

10. replacing tabs with emulated tabs

11. tab versus tab

12. ALT-TAB bug (ALT-TAB on empty desktop, KDE1.1.2)

13. tcsh and problems with AUTOLIST via the tab key