Installing elm 2.3.11 on RS6000

Installing elm 2.3.11 on RS6000

Post by Fred Huc » Wed, 08 May 1991 03:01:06



Well, the subject line says it all. Has anyone compiled the elm package on
the fast and buggy RS6000(/320) ?

Please e-mail to


Thankx...

Fred Hucht, Physics Departement, University of Duisburg, Germany

 
 
 

Installing elm 2.3.11 on RS6000

Post by Fred Huc » Thu, 09 May 1991 01:05:41



>Well, the subject line says it all. Has anyone compiled the elm package on
>the fast and buggy RS6000(/320) ?
>Please e-mail to

>Thankx...
>Fred Hucht, Physics Departement, University of Duisburg, Germany

OK, here is the solution:
1) Create a new compiler-stanza for bsdcc in /etc/xlc.cfg as described in
   /usr/lpp/bos/bsdport and link /bin/xlc to /bin/bsdcc.
2) Run the elm Configure-script. Tell him to use bsdcc instead of cc at the
   point "...cc options... [cc] ? "
   At the end of Configure do a shell-escape and change termlib to -lcurses.
   End the shell-escape and complete Configure.
3) make it. Some warnings occure, but I ignored them.

I think thats all. Thanks to the following people for the hints:




Quote:> To make elm read the X window size I added
>        #if AIX
>        #define TIOCGWINSZ
>        #include <sys/ioctl.h>        /* non-standard, for TIOCGWINSZ */
>        #endif
> to src/curses.c

Fred Hucht, Physics Departement, University of Duisburg, Germany

 
 
 

1. mod_ssl 2.3.11-1.3.6 & 2.2.8-STABLE install problems

Hey all,

FreeBSD 2.2.8-STABLE
openssl-0.9.4
apache_1.3.6
mod_ssl-2.3.11-1.3.6
rsaref-2.0
mm-1.0.9

I'm getting the following errors compiling this.  I'm following the
configurartion instructions to the t; serveral times with no luck.  I've
done it with and without the mm support.  Any help would be appreciated.
Thanks!

Dave

===> src/modules/ssl
gcc -c  -I../../os/unix -I../../include   -funsigned-char -DMOD_SSL=203111
-DUSE_HSREGEX -DEAPI `../../apaci` -DSSL_COMPAT -I/web/sr                
c/openssl-0.9.4/include -DMOD_SSL_VERSION=\"2.3.11\" mod_ssl.c
In file included from mod_ssl.c:65:
mod_ssl.h:496: parse error before `AP_MM'
mod_ssl.h:496: warning: no semicolon at end of struct or union
mod_ssl.h:511: parse error before `}'
mod_ssl.h:511: warning: data definition has no type or storage class
*** Error code 1

Stop.
*** Error code 1

Stop.
*** Error code 1

Stop.
*** Error code 1

Stop.
*** Error code 1

Stop.

2. Arrgh! Something keeps chmod-ing my device files!!!

3. ppp 2.3.11 not working

4. RS/6000's LinuxPPC Supported

5. Where is latest pppd 2.3.11 please?

6. Simple socket protocol

7. 2.3.11 ppp, framing errors are killing me

8. Why does rplay loop sounds ??

9. trouble ppp 2.3.11 & Kernel 2.2.16

10. Kernel 2.3.11 - error

11. ppp 2.3.11 hanging..

12. pppd.2.4.1 fails where pppd.2.3.11 worked. Why? (fwd)

13. elm 2.4 on IBM RS6000