HACMP/ESCRM / OPS / cllockd / cllockdES

HACMP/ESCRM / OPS / cllockd / cllockdES

Post by pseri » Thu, 18 Jul 2002 09:26:18



Our problem is with Oracle Parallel  Server and HACMP /ESCRM with the
following description:

We have two pSeries 6H1 with a SSA 7133-D40 configured in concurrent
mode
The heartbeat is defined by a serial rs232 network throught the third
serial port in both machines.
We have two 10/100 Mbps ethernet cards in each servers that are used
for boot, service and standby pourpose.  Also we have an additional
network with a gbit ethernet cards to define the DLM (distributed lock
manager) that are configured in HACMP as service adapters.

The Operating system is AIX 4.3.3. Level ML_09
The HACMP /ESCRM version is 4.4
The DB is Oracle 7.3.3 with OPS.

The cluster has been configured and is working normally; the cluster
manager service, the clinfo and so start fine without errors.

The Concurrent Volume Group and concurrent Logical volumes has been
defined as well.

The problem is when we are trying to startup the cllockd service, it
doesnt startup.   We have changed to true the option to start the
cllockd service when we start the cluster services.

We are trying to startup this service because the OPS installation
require this service.

Someone can help us to solve this issue or know another way to install
the OPS with this kind of configuration?

Thank you very much for your help.

 
 
 

HACMP/ESCRM / OPS / cllockd / cllockdES

Post by Simon Marches » Thu, 18 Jul 2002 18:11:08



>Our problem is with Oracle Parallel  Server and HACMP /ESCRM with the
>following description:

>We have two pSeries 6H1 with a SSA 7133-D40 configured in concurrent
>mode
>The heartbeat is defined by a serial rs232 network throught the third
>serial port in both machines.
>We have two 10/100 Mbps ethernet cards in each servers that are used
>for boot, service and standby pourpose.  Also we have an additional
>network with a gbit ethernet cards to define the DLM (distributed lock
>manager) that are configured in HACMP as service adapters.

>The Operating system is AIX 4.3.3. Level ML_09
>The HACMP /ESCRM version is 4.4
>The DB is Oracle 7.3.3 with OPS.

>The cluster has been configured and is working normally; the cluster
>manager service, the clinfo and so start fine without errors.

>The Concurrent Volume Group and concurrent Logical volumes has been
>defined as well.

>The problem is when we are trying to startup the cllockd service, it
>doesnt startup.

What are the symptoms? Any log output?

Quote:>We have changed to true the option to start the
>cllockd service when we start the cluster services.

>We are trying to startup this service because the OPS installation
>require this service.

Which version of OPS? 7.3.3? Do Oracle still support that? I thought
that as of O8i, Oracle provided their own lock manager and that cllockd
was not needed. Maybe they provided it in a 7.x release.

- Show quoted text -

Quote:>Someone can help us to solve this issue or know another way to install
>the OPS with this kind of configuration?

>Thank you very much for your help.


 
 
 

HACMP/ESCRM / OPS / cllockd / cllockdES

Post by pseri » Fri, 19 Jul 2002 05:46:14


Thank you Simon.

There are no symptoms, after startup the services, I use the option to
see the services status and just said that cllockd is inoperative.

Really i dont know if is possible to configure the OPS with the
cllockd that come with HACMP, but we dont know how use the Oracle DLM
that come with Oracle Parallel Server.

Somebody know how can we do to configure the OPS with HACMP?.   Thank
you very much for your help.



> >Our problem is with Oracle Parallel  Server and HACMP /ESCRM with the
> >following description:

> >We have two pSeries 6H1 with a SSA 7133-D40 configured in concurrent
> >mode
> >The heartbeat is defined by a serial rs232 network throught the third
> >serial port in both machines.
> >We have two 10/100 Mbps ethernet cards in each servers that are used
> >for boot, service and standby pourpose.  Also we have an additional
> >network with a gbit ethernet cards to define the DLM (distributed lock
> >manager) that are configured in HACMP as service adapters.

> >The Operating system is AIX 4.3.3. Level ML_09
> >The HACMP /ESCRM version is 4.4
> >The DB is Oracle 7.3.3 with OPS.

> >The cluster has been configured and is working normally; the cluster
> >manager service, the clinfo and so start fine without errors.

> >The Concurrent Volume Group and concurrent Logical volumes has been
> >defined as well.

> >The problem is when we are trying to startup the cllockd service, it
> >doesnt startup.

> What are the symptoms? Any log output?

> >We have changed to true the option to start the
> >cllockd service when we start the cluster services.

> >We are trying to startup this service because the OPS installation
> >require this service.

> Which version of OPS? 7.3.3? Do Oracle still support that? I thought
> that as of O8i, Oracle provided their own lock manager and that cllockd
> was not needed. Maybe they provided it in a 7.x release.

> >Someone can help us to solve this issue or know another way to install
> >the OPS with this kind of configuration?

> >Thank you very much for your help.

 
 
 

HACMP/ESCRM / OPS / cllockd / cllockdES

Post by pseri » Fri, 19 Jul 2002 06:23:05


This is the messages when the services are started up:

Jul 17 2002 11:11:17
/usr/es/sbin/cluster/utilities/clstart : called with flags -sm -i -l -b

0513-004 The Subsystem or Group, topsvcs, is currently inoperative.
0513-059 The topsvcs Subsystem has been started. Subsystem PID is 40716.
0513-059 The grpsvcs Subsystem has been started. Subsystem PID is 51214.
0513-059 The grpglsm Subsystem has been started. Subsystem PID is 26824.
0513-059 The emsvcs Subsystem has been started. Subsystem PID is 49142.
0513-059 The emaixos Subsystem has been started. Subsystem PID is 50370.
0513-059 The clstrmgrES Subsystem has been started. Subsystem PID is 37182.
0513-059 The cllockdES Subsystem has been started. Subsystem PID is 48452.
0513-059 The clsmuxpdES Subsystem has been started. Subsystem PID is 50872.
0513-059 The clinfoES Subsystem has been started. Subsystem PID is 48480.
Jul 17 2002 11:11:46

Completed execution of /usr/es/sbin/cluster/etc/rc.cluster
with parameters: -boot -N -b -l -i.
Exit Status = 0.

But whe we use the show service option we see the following:

Subsystem         Group            PID     Status
 clstrmgrES       cluster          41064   active
 clinfoES         cluster          42840   active
 clsmuxpdES       cluster          42326   active
 cllockdES        lock                     inoperative

Thank you for your valued help.



> >Our problem is with Oracle Parallel  Server and HACMP /ESCRM with the
> >following description:

> >We have two pSeries 6H1 with a SSA 7133-D40 configured in concurrent
> >mode
> >The heartbeat is defined by a serial rs232 network throught the third
> >serial port in both machines.
> >We have two 10/100 Mbps ethernet cards in each servers that are used
> >for boot, service and standby pourpose.  Also we have an additional
> >network with a gbit ethernet cards to define the DLM (distributed lock
> >manager) that are configured in HACMP as service adapters.

> >The Operating system is AIX 4.3.3. Level ML_09
> >The HACMP /ESCRM version is 4.4
> >The DB is Oracle 7.3.3 with OPS.

> >The cluster has been configured and is working normally; the cluster
> >manager service, the clinfo and so start fine without errors.

> >The Concurrent Volume Group and concurrent Logical volumes has been
> >defined as well.

> >The problem is when we are trying to startup the cllockd service, it
> >doesnt startup.

> What are the symptoms? Any log output?

> >We have changed to true the option to start the
> >cllockd service when we start the cluster services.

> >We are trying to startup this service because the OPS installation
> >require this service.

> Which version of OPS? 7.3.3? Do Oracle still support that? I thought
> that as of O8i, Oracle provided their own lock manager and that cllockd
> was not needed. Maybe they provided it in a 7.x release.

> >Someone can help us to solve this issue or know another way to install
> >the OPS with this kind of configuration?

> >Thank you very much for your help.

 
 
 

1. CLLOCKD, hacmp, and master/remaster node to node

An attempt to determine where my resources and locks are "mastered" in a
concurrent HA cluster has turned up almost useless info, certainly
unreliable.

The HACMP 4.2.1 documentation ( the full set ) falls terribly short in the
area of lock management within the cluster.  Have any of you found a better
source for info on the lock manager under AIX.  I'm particularly interested
in documentation that describes the output of the cldiag => debug => cllockd
code.  Where are my lock resources allocated and mastered?  Also, I'd like
to be able to write a tool that would implement a re-mastering of specific
sets of locks.

Simply parsing through the cld_debug.out file to get lock info is not the
best method.  There must be a better, more dynamic way to get at the lock
structures in the kernel.

Please cc any responses to my email address.

Thanks in advance,

-Kevin Brand

--
remove the x for email response

2. Plugger not working with Mozilla 0.9.6

3. HACMP/es + nfs + ops

4. DNS internal root

5. AIX - OPS - 9I - HACMP

6. Quicktime VR?

7. HACMP, OPS install

8. new to linux

9. setsockopt( fh, IPPROTO_TCP, TCP_NODELAY, &op, sizeof( op ) )

10. Does hacmp synchronisations need hacmp started ?

11. Difference between HACMP and HACMP/ES

12. Weird behaviour after upgrading from HACMP/ES 4.4.0 to HACMP/ES 4.4.1

13. add struct file* to ->direct_IO addr space op