L2 cache confusion - please don't ignore!

L2 cache confusion - please don't ignore!

Post by McpTro » Tue, 08 Jul 2003 22:19:50



hi all,

i've a 43p-260 2 proc machine. please look the the following cmd output.
the handbook tells me that the machine should have 4mb L2 cache for each
processor. but lsdev shows only one L2cache device, lsattr tells me that
it has 4mb (but only one time, not for each processor), lscfg tells me
that the one L2 cache is located on both locations for each proc.

i can't figure out what that means. have i 2 time 4mb L2cache or only once?

please help...

thanx.

rg.
mike

----------

# lsdev -Cc procsssor
proc0 Available 00-00 Processor
proc2 Available 00-02 Processor

# lsdev -Cc memory
mem0     Available 00-00 Memory
L2cache0 Available 00-00 L2 Cache

# lscfg -pvl proc0
   DEVICE            LOCATION          DESCRIPTION

   proc0             00-00             Processor

         Device Specific.(YL)........P1-C1

   PLATFORM SPECIFIC

   Name:  PowerPC,POWER3

     Device Type:  cpu
     Physical Location: P1-C1

# lscfg -pvl proc2
   DEVICE            LOCATION          DESCRIPTION

   proc2             00-02             Processor

         Device Specific.(YL)........P1-C2

   PLATFORM SPECIFIC

   Name:  PowerPC,POWER3

     Device Type:  cpu
     Physical Location: P1-C2

# lscfg -pvl L2cache0
   DEVICE            LOCATION          DESCRIPTION

   L2cache0          00-00             L2 Cache

   PLATFORM SPECIFIC

   Name:  l2-cache
     Node:  l2-cache
     Device Type:  cache
     Physical Location: P1-C1

   Name:  l2-cache
     Node:  l2-cache
     Device Type:  cache
     Physical Location: P1-C2

# lsattr -El L2cache0
size 4096 Size of L2 cache in Kbytes False

-------------

 
 
 

1. bzImage & L2 cache hang @ 'LILO loading Linux...'

Hi,

booting a compiled kernel ...
When I compile using bzImage (bzlilo), my computer hangs at 'LILO loading
Linux'
When I compile using zImage (zlilo), my computer boots just fine.

This sux 'cause I have to keep my kernel really small < 500 K to use zlilo

I can use bzImage IF AND ONLY IF I disable L2 cache in the bios. If I do
this then it boots fine.

Any known solutions ?

Matt

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in

More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

2. SYNC and ASYNC disks on 320H

3. How to set up Diagela-- please don't ignore and answer

4. jumpy cursor movement in 1.0 with rlogin/telnet

5. Why won't RH7 boot with L1/L2 cache enabled?

6. WALLACE AND GROMMIT

7. Please don't feed 'as400'

8. daily.news permissions?

9. Please ignore the '1', Sorry .

10. please send me a 'fax' script (ignore prev.)

11. SORT: Why don't -b and -i ignore tabs?

12. don't ignore chipset specific sector size (Was Re: bio too big device)

13. ISDN(don't ignore me!)