Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

Re. bffcreate -X doesn't work Re: bffcreate -X Doesn't Work

Post by Frank Kraem » Tue, 10 Nov 1992 18:01:14




>I was setting up and "install server," following the instructions
>in the AIX installation manual, and the load of the boot images and
>ptf's ("bffcreate" is the command that's executed from SMIT)
>kept failing.  Each time the failure happened, the jfs I'd
>created for them showed up with no space available.

bffcreate first restores all images from the tape to /tmp (default)
and than does a 'restore -p' to pack them in big files and place these
files in /usr/sys/inst.images. It's much more easier to use 'dd' to
copy the files directly from the tape to disk. The only thing you have
to take care about it the naming. If all images are copied run 'inutoc'
on the directory were you placed your files this will create the
table of contents files '.toc'.

frank ;-)

.----------------------------------------------------------------------.
| E-Mail: FRANVM3(KRAEMERF)                 - IBM VNET  "Yes, I'm one  |
| ======  IBMMAIL(DEIBM27S)                 - IBM-Mail   of those      |
|         DE.IBMX400.IBMMAIL.KRAEMER.KRAEME - X.400      stupid IBM    |

| Voice : +49-(0)611/776-364                                           |
| Mail  : Abraham-Lincoln Street 26, 6200 Wiesbaden, Germany           |
'----------------------------------------------------------------------'

 
 
 

1. bffcreate -X Doesn't Work

I just spent/lost 5 hours yesterday discovering a "known bug" in AIX
3.2.x and thought I'd share it in the hope others can profit.

I was setting up and "install server," following the instructions
in the AIX installation manual, and the load of the boot images and
ptf's ("bffcreate" is the command that's executed from SMIT)
kept failing.  Each time the failure happened, the jfs I'd
created for them showed up with no space available.

The SMIT "Copy Software to Hard Disk for Future Installation"
screen clearly has the "expand filesystem if needed" option,
which I'd checked off.  Nonetheless, be warned:

THIS DOES NOT WORK.

I ended up having to work in two windows, chfs-ing the filesystem
again and again, trying to stay ahead of the load from tape.
(Naturally, I didn't want to expand it to much, so I was doing
it 8MB at a time.)  Couple of times I wasn't quick enough, and
the process had to be restarted.

After finally having gotten all the stuff loaded, I called IBM
defect support, who confirmed that bffcreate's -X option
doesn't work.  There is no fix now, and, they say, will not
be one until "the next release."  I asked if "the next
release" means 3.2.4 or 3.3 or 4.0 or what, but the
technician wasn't able to tell me.

2. Setting up a web server...

3. PPP doesn't die, it just doesn't work anymore

4. Where does the data segment start?

5. : PLIP start up doesn't report problems but also doesn't work?

6. connecting to internet

7. Oh, fooey -- drivers don't work, rpm doesn't work

8. hylaFAX or better option from open source?

9. ping -g 'gateway-IP' 'host-IP' DOESN'T work!

10. 'ppp-on' Works, 'ifup ppp0' Doesn't

11. 'kill -HUP pid' doesn't work for restart!

12. Why doesn't sed 's/$/^M/' work as expected?

13. 'ls' doesn't work on net-2 in.ftpd for shadow passwords