Vitural IP setup on AIX5.1L?

Vitural IP setup on AIX5.1L?

Post by Jack » Sat, 09 Jun 2001 00:53:22



Hi All:
    Does anyone have setup the vitural IP address on AIX5.1? I have
try it use "smitty mkinetvi", but can not work. I don't know how to
set the "network interface" item. Need help.

     Thanks a lot!

Jack Li

 
 
 

Vitural IP setup on AIX5.1L?

Post by Simon Marches » Wed, 13 Jun 2001 21:10:01


What do you see when you try it?

> Hi All:
>     Does anyone have setup the vitural IP address on AIX5.1? I have
> try it use "smitty mkinetvi", but can not work. I don't know how to
> set the "network interface" item. Need help.

>      Thanks a lot!

> Jack Li


 
 
 

Vitural IP setup on AIX5.1L?

Post by Jack » Thu, 14 Jun 2001 05:15:08


I try to setup both the interface en1(not available in system) and en0
(available and have another IP address)
The information get from smit.log:
1. set on en1(en1 is not available on box)
[Jun 12 2001, 15:01:46]

    Command_to_Execute follows below:

Quote:>> mkdev -c if -s VI -t vi -a netaddr='172.30.2.99' -a

netmask='255.255.0.0' -w 'en1' -a state='up'

    Output from Command_to_Execute follows below:

---- start ----

Method error (/usr/lib/methods/chgif):
        0514-068 Cause not known.
0821-510 ifconfig: error calling entry point for
/usr/lib/drivers/if_en: The specified device does not exist.
0821-223 chgif: Cannot get records from CuAt.
0821-229 chgif: ifconfig command failed.
The status of"en1" Interface in the current running system is
uncertain.

Method error (/usr/lib/methods/udefif):
        0514-027 The specified device is in the wrong state to
                 perform the requested function.
0821-123 udefif: en1 must not be in either the STOPPED or the
AVAILABLE state.

---- end ----

2.setup en0

Method error (/usr/lib/methods/chgif):                            
        0514-006 Cannot retrieve an object from the device        
                 configuration database.                  
0821-224 chgif: Expected one if instance, retrieved 0.

Method error (/usr/lib/methods/udefif):
        0514-006 Cannot retrieve an object from the device
                 configuration database.
0821-122 udefif: Expected one interface instance, retrieved 0.

Thanks.

Jack Li


> What do you see when you try it?


> > Hi All:
> >     Does anyone have setup the vitural IP address on AIX5.1? I have
> > try it use "smitty mkinetvi", but can not work. I don't know how to
> > set the "network interface" item. Need help.

> >      Thanks a lot!

> > Jack Li

 
 
 

Vitural IP setup on AIX5.1L?

Post by Urban A. Haa » Thu, 14 Jun 2001 05:45:58


Out of curiosity, does this happen in the C locale? Maybe it's a
localization problem with new code.

--
Urban A. Haas
CEO - Urban Technology, Inc.
Minneapolis, MN  USA
Phone: (952) 595-8810    Fax: (952) 595-8710

Web: http://www.urbantechnology.com

This e-mail was composed of 100% recycled bits.

> I try to setup both the interface en1(not available in system) and en0
> (available and have another IP address)
> The information get from smit.log:
> 1. set on en1(en1 is not available on box)
> [Jun 12 2001, 15:01:46]

>     Command_to_Execute follows below:
> >> mkdev -c if -s VI -t vi -a netaddr='172.30.2.99' -a
> netmask='255.255.0.0' -w 'en1' -a state='up'

>     Output from Command_to_Execute follows below:

> ---- start ----

> Method error (/usr/lib/methods/chgif):
> 0514-068 Cause not known.
> 0821-510 ifconfig: error calling entry point for
> /usr/lib/drivers/if_en: The specified device does not exist.
> 0821-223 chgif: Cannot get records from CuAt.
> 0821-229 chgif: ifconfig command failed.
> The status of"en1" Interface in the current running system is
> uncertain.

> Method error (/usr/lib/methods/udefif):
> 0514-027 The specified device is in the wrong state to
>          perform the requested function.
> 0821-123 udefif: en1 must not be in either the STOPPED or the
> AVAILABLE state.

> ---- end ----

> 2.setup en0

> Method error (/usr/lib/methods/chgif):
>         0514-006 Cannot retrieve an object from the device
>                  configuration database.
> 0821-224 chgif: Expected one if instance, retrieved 0.

> Method error (/usr/lib/methods/udefif):
>         0514-006 Cannot retrieve an object from the device
>                  configuration database.
> 0821-122 udefif: Expected one interface instance, retrieved 0.

> Thanks.

> Jack Li




- Show quoted text -

> > What do you see when you try it?


> > > Hi All:
> > >     Does anyone have setup the vitural IP address on AIX5.1? I have
> > > try it use "smitty mkinetvi", but can not work. I don't know how to
> > > set the "network interface" item. Need help.

> > >      Thanks a lot!

> > > Jack Li

 
 
 

Vitural IP setup on AIX5.1L?

Post by Paul Landa » Thu, 14 Jun 2001 19:04:42


Try using an interface name of 'vi0' instead of 'en1'.
When you use a name like 'enX' aix thinks there is a
real ethernet adapter, but of course this is a virtual
interface, so you need a name that does not match a
real interface type.

Paul Landay

 
 
 

Vitural IP setup on AIX5.1L?

Post by Jack » Fri, 15 Jun 2001 03:34:23



> Try using an interface name of 'vi0' instead of 'en1'.
> When you use a name like 'enX' aix thinks there is a
> real ethernet adapter, but of course this is a virtual
> interface, so you need a name that does not match a
> real interface type.

> Paul Landay

I have try the vi0, the result is "OK" but have a error information.

Here is the smit.log:

mkdev -c if -s VI -t vi -a netaddr='172.30.2.99' -a netmask='255.255.0.0' -w
'vi0' -a state='up'
---- start ----

vi0 Available

[Jun 13 2001, 08:13:02]
    Exiting SMIT

    **** ERROR ****

1800-105 system("sync"): system call failed:
^P.

---- end ----

use "lsattr -E -l vi0" can see the attribute of vi0

use "netstat -rn"  can see there add another entry "172.30.2.99"

Destination      Gateway           Flags   Refs     Use  If   PMTU Exp Groups

Route Tree for Protocol Family 2 (Internet):
default          172.30.0.1        UGc       0        0  en0     -   -
127/8            127.0.0.1         U         5     2622  lo0     -   -
172.30/16        172.30.2.63       U        38     2967  en0     -   -
172.30.2.99      127.0.0.1         UH        0        0  lo0     -   -

on the local host can ping 172.30.2.99
but from other host cannot ping 172.30.2.99

about after 20 minute the TCP/IP cannot work.

Thanks.

Jack Li

 
 
 

Vitural IP setup on AIX5.1L?

Post by Paul Landa » Fri, 15 Jun 2001 05:43:17


You can ignore the '1800-105 sync' error message.
It is an intermitent bug in smit where it is trying
to flush the smit.log/smit.script, it has nothing
to do with the creation of the virtual ip interface.
On second thought you might as well report it to
IBM service, the more they hear about it the quicker
they will fix it.

Quote:> use "netstat -rn"  can see there add another entry "172.30.2.99"

Does "netstat -in" show the new interface ('vi0') being up?

Are you sure all the 'en1' referenced to 172.30.2.99
were cleaned up properly (e.g. 'rmdev -l en1 -d')?

Quote:> but from other host cannot ping 172.30.2.99

Have you tried a traceroute from the other host
to make sure it is coming into the aix box?
Have you tried a traceroute from the aix box
back to the other host to make sure the outbound
routes are ok?

Quote:> about after 20 minute the TCP/IP cannot work.

All of tcp/ip or just the virtual interface?
Could this be a dynamic route getting deleted
or an arp entry aging out?

Paul Landay

 
 
 

Vitural IP setup on AIX5.1L?

Post by Paul Landa » Fri, 15 Jun 2001 19:52:35


Maybe you should look at the VIPA section (5.5) of the "AIX
5L Differences Guide", SG24-5765-01, which is online at:
  http://www.redbooks.ibm.com/redbooks/SG245765.html
or
  http://www.redbooks.ibm.com/pubs/pdfs/redbooks/sg245765.pdf

Your 'netstat -rn' output only shows one real interface ('en0')
and I think VIPA is of questionable use when there is only one
real interface.  To me it is on most value when there are
multiple interfaces and you want to to present one ip name/address
to all remotes on all subnets.  When you have only one interface,
and 'alias' is a much simpler way to add a second ip name/address
for a box.

Paul Landay

 
 
 

1. AIX5.1L ML03 cd size problem

Hi !

Any suggestions on how to split AIX5.1L ML03 between 2 CDs ?
Even the diff between ML02 and ML03 is more than 1 CD.

I could of course creat a compressed tarfile which would fit
on 1 CD, but would prefer to just install from CD without
packing up all stuff first.

Regards
--

2. What is fdprintf (and has anyone compiled GNU's fax software)?

3. Need AIX5.1L ??

4. Newbie needs help

5. Permanent Vitural Servers IP's

6. Announce: Automatic Hardware Configuration project

7. Problems after migration AIX5.1 > AIX5.2

8. X in Slackware

9. named based vitural host

10. Help with setup of IP-IP Tunnel on linux

11. Static IP network setup with a dynamic dial-up IP from ISP

12. iv-3.1l.2: InterViews 3.1 for Linux with shared libraries (update)

13. AIX V5.1L/ WLM