3-button PS2 mouse on a 390 - middle button not working

3-button PS2 mouse on a 390 - middle button not working

Post by Jeffrey Ros » Sat, 28 Sep 2002 08:04:20



Hi.
We have previosly used a 3-button serial mouse on AIX 3.2.5 but have just
upgraded to using PS2 and AIX 4.3.3.
"lsdev -Cc mouse" reports "mouse0 Available 00-00-0M-00 2 button mouse"
which doesn't look good (although our modern 44P witha  PS2 3-button mouse
reports only 2 buttons and yet all three actually work!).
Anyone got a 3-button PS2 mouse to work on a MCA machine?
Comparing lslpp between this machine and one with a working 3-button mouse I
see little in the way of differences.  I've brought
devices.isa-sio.chrp.8042.rte and devices.isa-sio.km.rte up to 4.3.3.50
(since that seemed to be the main difference) but no change.
The middle button is obviously detected.  When pressed the cursor freezes
until the button is released.  However the usual mwm menu for button 2 is
not displayed and our main application does not detect the middle button
being pressed.  We have replaced the mouse with a known good one, but that
didn't help.
Any suggestions?
Thanks,
Jeffrey.
 
 
 

3-button PS2 mouse on a 390 - middle button not working

Post by Daniel Boo » Sun, 29 Sep 2002 12:15:39


Run 'diag -a'

If it's connected via a KVM switch, connect the mouse directly to the
machine (for setup only). At KVMs with repeater machine are unable to
detect the mouse itself.

 
 
 

3-button PS2 mouse on a 390 - middle button not working

Post by Jose Pina Coelh » Wed, 02 Oct 2002 08:27:54



> Anyone got a 3-button PS2 mouse to work on a MCA machine?

A customer of mine used to run a trackman marble on a 250.

Worked perfectly.

 
 
 

1. Middle button on 3-button mouse not registering

I have a generic 3-button mouse which claims to be MS mouse
compatible.  However, I'm unable to get XF86 to recognize the middle
mouse button...

I've tried the MS protocol (which works except for the middle button),
and the MouseSystems protocol (which doesn't work at all).  I've tried
all the options I could find, too.

thanks,
-eric

2. Problem with RedHat 5.0 Custom CD-ROM

3. Setting up 3-button mouse with the middle button as wheel?

4. privacy on Unix-servers

5. -> 3-button mouse, 2nd button not work

6. CAn't Connect to Internet

7. Can 2-button mouse do 3-button mouse works?

8. No joy with Radeon 9500 Pro ATI driver - broken agp support ?

9. KeyMouse 3-button mouse - anyone get the third button working?

10. How to make the middle button work in a 3 button mouse?

11. middle mouse button on three button mice

12. Help: 2nd mouse button (3 button mouse) not working right

13. : 2-button vs 3-button mouse