runaway process

runaway process

Post by dwilliam.. » Wed, 14 Jun 2000 04:00:00



I am running an RS6000 J40 4way with 1gb ram, a progress v8.3 database.

At odd intervals i am getting a process that hangs the entire rs6000
with no errors. Even the console stops.

Dumps show massive I/O wait

Help?

Dean Williams

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

runaway process

Post by dwilli.. » Wed, 14 Jun 2000 04:00:00


I am running an RS6000 J40 4way with 1gb ram, a progress v8.3 database.

At odd intervals i am getting a process that hangs the entire rs6000
with no errors. Even the console stops.

Dumps show massive I/O wait

Help?

Dean Williams

Sent via Deja.com http://www.deja.com/
Before you buy.

 
 
 

runaway process

Post by Steven Langdal » Wed, 14 Jun 2000 04:00:00


Hello Dean

I'm soory I dont have an answer to your question, but I noticed you are
running progress.  We are looking at implementing a large progress DB
but i've been told it is NOT multithreaded.  What is your experience
with this??

Thanks

Steven

* Sent from Novell Discussion Forums http://novell.remarq.com The Internet's Discussion Network *
The fastest and easiest way to search and participate in Usenet - Free!

 
 
 

runaway process

Post by Michael Troelse » Wed, 14 Jun 2000 04:00:00


Hi,

It sound like you Before Image file is expanding, causing all other Progress
process to hang.

How big is you bi cluster and how check points per sec?

Take a look at www.peg.com.

Regards
Michael Troelsen


> I am running an RS6000 J40 4way with 1gb ram, a progress v8.3 database.

> At odd intervals i am getting a process that hangs the entire rs6000
> with no errors. Even the console stops.

> Dumps show massive I/O wait

> Help?

> Dean Williams

> Sent via Deja.com http://www.deja.com/
> Before you buy.

 
 
 

runaway process

Post by Michael Troelse » Wed, 14 Jun 2000 04:00:00


Hi,

It sound like you Before Image file is expanding, causing all other Progress
process to hang.

How big is you bi cluster and how check points per sec?

Take a look at www.peg.com.

Regards
Michael Troelsen


> I am running an RS6000 J40 4way with 1gb ram, a progress v8.3 database.

> At odd intervals i am getting a process that hangs the entire rs6000
> with no errors. Even the console stops.

> Dumps show massive I/O wait

> Help?

> Dean Williams

> Sent via Deja.com http://www.deja.com/
> Before you buy.

 
 
 

runaway process

Post by artu » Thu, 15 Jun 2000 04:00:00


Well, you did not sypply enough information for this. Give AIX version,
give progress patch level, look all logs (progress and AIX).  Tell us how
big is your database, did you run promon utility ? did you run sar or
iostat ? did you check
what process were running ? May be swap was nearly full ? do you use RAID
for database ?
Once I had similar problem, but that occured while database was rebuilt.
The problem was with incorrect low/high watermarks. You should also check
how many processes you allow to run under user (in AIX 4.3.1 there were
problems
with it and performance). If you need more info give us more info.

Artur


> I am running an RS6000 J40 4way with 1gb ram, a progress v8.3 database.

> At odd intervals i am getting a process that hangs the entire rs6000
> with no errors. Even the console stops.

> Dumps show massive I/O wait

> Help?

> Dean Williams

> Sent via Deja.com http://www.deja.com/
> Before you buy.

 
 
 

runaway process

Post by dwilliam.. » Sat, 17 Jun 2000 04:00:00


Sorry about the lack of info.

Progress db is 8gb based on 8.3b03 char. and on aix v4.3.2.0
unfortunately when the machine stops i cant get on at all to run
anything, i dont get any errors or even warnings.

Any help would be appreciated.

Thanks

Dean



> Well, you did not sypply enough information for this. Give AIX
version,
> give progress patch level, look all logs (progress and AIX).  Tell us
how
> big is your database, did you run promon utility ? did you run sar or
> iostat ? did you check
> what process were running ? May be swap was nearly full ? do you use
RAID
> for database ?
> Once I had similar problem, but that occured while database was
rebuilt.
> The problem was with incorrect low/high watermarks. You should also
check
> how many processes you allow to run under user (in AIX 4.3.1 there
were
> problems
> with it and performance). If you need more info give us more info.

> Artur


> > I am running an RS6000 J40 4way with 1gb ram, a progress v8.3
database.

> > At odd intervals i am getting a process that hangs the entire rs6000
> > with no errors. Even the console stops.

> > Dumps show massive I/O wait

> > Help?

> > Dean Williams

> > Sent via Deja.com http://www.deja.com/
> > Before you buy.

Sent via Deja.com http://www.deja.com/
Before you buy.
 
 
 

1. Restarting runaway processes?? Can it be done??

G'day All,
        Just trying to find out if there is a command to restart a process from
a failed login. Ie. you type ps and can see the PID no. I know you can kill it
using kill -9 PID but can you restart it?

Thanks for any help,
        Alistair (Furthest from a unix guru u could think of :)

2. MSIE 2.1 (Mac) won't load images from Apache SSL

3. Runaway process on SP2 w/AIX4.1.4

4. Linux and HP 4L

5. Killing runaway processes not logged into

6. Ensoniq Soundscape VIVO90 PnP

7. script to monitor and kill/restart runaway processes on Linux server

8. Yggdrasil CD install and Soundman Wave

9. Tracking runaway processes

10. JDK1.4.1 and runaway processes.

11. Runaway processes (not zombied)

12. runaway process/problem solving methodology

13. Runaway Processes