Tomcat 3.1, AIX 4.3.3 and Java 1.2.2

Tomcat 3.1, AIX 4.3.3 and Java 1.2.2

Post by Markus Zah » Fri, 19 May 2000 04:00:00



Has anyone else tried to use Tomcat 3.1 - the Java Servlets and
JavaServer Pages Reference Implementation, http://jakarta.apache.org/ -
on AIX 4.3.3 with IBM's Java 1.2.2?

I've installed IBM's latest version of Java 1.2.2 (java full version
"J2RE 1.2.2 IBM build ca122-20000420") on AIX 4.3.3 (maintenance level 2
containing all the fixes noted in the Java 1.2.2 README.html), fetched
the binary version of Tomcat 3.1. But when I try to start Tomcat, it
just coredumps.

Any ideas would be greatly appreciated
++Markus
______________________________________________________________________
Dr. Markus Zahn, Universit?t Augsburg, Rechenzentrum, D-86135 Augsburg
Tel./Fax: ...................................... (0821) 598-2004/-2028
World Wide Web: ....................... http://www.RZ.Uni-Augsburg.DE/

 
 
 

Tomcat 3.1, AIX 4.3.3 and Java 1.2.2

Post by Hartwig Bol » Sat, 20 May 2000 04:00:00


On Thu, 18 May 2000 14:29:43 +0200, Markus Zahn

Hi Markus,

I'm running Tomcat 3.1 under AIX 4.3.2 with Java 1.1.8 and its work
fine so far.

Have you tried to install Maintenance Level 03 for AIX 4.3.3. which is
already available.

Regards,
Hartwig

Quote:>Has anyone else tried to use Tomcat 3.1 - the Java Servlets and
>JavaServer Pages Reference Implementation, http://jakarta.apache.org/ -
>on AIX 4.3.3 with IBM's Java 1.2.2?

>I've installed IBM's latest version of Java 1.2.2 (java full version
>"J2RE 1.2.2 IBM build ca122-20000420") on AIX 4.3.3 (maintenance level 2
>containing all the fixes noted in the Java 1.2.2 README.html), fetched
>the binary version of Tomcat 3.1. But when I try to start Tomcat, it
>just coredumps.

>Any ideas would be greatly appreciated
>++Markus
>______________________________________________________________________
>Dr. Markus Zahn, Universit=E4t Augsburg, Rechenzentrum, D-86135 Augsburg
>Tel./Fax: ...................................... (0821) 598-2004/-2028
>World Wide Web: ....................... http://www.RZ.Uni-Augsburg.DE/


 
 
 

Tomcat 3.1, AIX 4.3.3 and Java 1.2.2

Post by q.. » Wed, 07 Jun 2000 04:00:00


Hartwig,
 I have configured Tomcat to work with AIX 4.3.3 and JDK 1.2.2 as well
and Tomcat itself seems to be working fine. Have you had any success in
getting the jserv module to have Tomcat work with Apache working
correctly? I am always stuck on a apxs error:

ld -H512 -T512 -bhalt:4 -bM:SRE -bnoentry -
bI:/usr/HTTPServer2/apachesrc/apache-1.3/src/support/httpd.exp  -
bE:`echo apxs|sed -e s:.so$:.exp:` -lc -o mod_jserv.so mod_jserv.o
jserv_wrapper_win.o jserv_wrapper_unix.o jserv_wrapper.o
jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o
jserv_mmap.o jserv_image.o jserv_balance.o jserv_ajpv12.o
jserv_ajpv11.o autochange.o
ld: 0706-004 Cannot find or read export file: apxs
        ld:accessx(): No such file or directory
apxs:Break: Command failed with rc=16711680

Anthony



> On Thu, 18 May 2000 14:29:43 +0200, Markus Zahn

> Hi Markus,

> I'm running Tomcat 3.1 under AIX 4.3.2 with Java 1.1.8 and its work
> fine so far.

> Have you tried to install Maintenance Level 03 for AIX 4.3.3. which is
> already available.

> Regards,
> Hartwig

> >Has anyone else tried to use Tomcat 3.1 - the Java Servlets and
> >JavaServer Pages Reference Implementation,

http://jakarta.apache.org/ -

- Show quoted text -

Quote:> >on AIX 4.3.3 with IBM's Java 1.2.2?

> >I've installed IBM's latest version of Java 1.2.2 (java full version
> >"J2RE 1.2.2 IBM build ca122-20000420") on AIX 4.3.3 (maintenance
level 2
> >containing all the fixes noted in the Java 1.2.2 README.html),
fetched
> >the binary version of Tomcat 3.1. But when I try to start Tomcat, it
> >just coredumps.

> >Any ideas would be greatly appreciated
> >++Markus

>______________________________________________________________________
> >Dr. Markus Zahn, Universit=E4t Augsburg, Rechenzentrum, D-86135
Augsburg
> >Tel./Fax: ...................................... (0821) 598-2004/-
2028
> >World Wide Web: ....................... http://www.RZ.Uni-
Augsburg.DE/

Sent via Deja.com http://www.deja.com/
Before you buy.
 
 
 

Tomcat 3.1, AIX 4.3.3 and Java 1.2.2

Post by mgari.. » Thu, 08 Jun 2000 04:00:00


Markus,
I have installed apache with tomcat 3.1 on AIX4.3.3 and JDK 1.2.2
it works fine. Try an alternate route by installing it on an
AIX 4.3.2 since it works on it for sure and try porting it to
the latest.



> Hartwig,
>  I have configured Tomcat to work with AIX 4.3.3 and JDK 1.2.2 as well
> and Tomcat itself seems to be working fine. Have you had any success
in
> getting the jserv module to have Tomcat work with Apache working
> correctly? I am always stuck on a apxs error:

> ld -H512 -T512 -bhalt:4 -bM:SRE -bnoentry -
> bI:/usr/HTTPServer2/apachesrc/apache-1.3/src/support/httpd.exp  -
> bE:`echo apxs|sed -e s:.so$:.exp:` -lc -o mod_jserv.so mod_jserv.o
> jserv_wrapper_win.o jserv_wrapper_unix.o jserv_wrapper.o
> jserv_watchdog.o jserv_utils.o jserv_status.o jserv_protocols.o
> jserv_mmap.o jserv_image.o jserv_balance.o jserv_ajpv12.o
> jserv_ajpv11.o autochange.o
> ld: 0706-004 Cannot find or read export file: apxs
>         ld:accessx(): No such file or directory
> apxs:Break: Command failed with rc=16711680

> Anthony



> > On Thu, 18 May 2000 14:29:43 +0200, Markus Zahn

> > Hi Markus,

> > I'm running Tomcat 3.1 under AIX 4.3.2 with Java 1.1.8 and its work
> > fine so far.

> > Have you tried to install Maintenance Level 03 for AIX 4.3.3. which
is
> > already available.

> > Regards,
> > Hartwig

> > >Has anyone else tried to use Tomcat 3.1 - the Java Servlets and
> > >JavaServer Pages Reference Implementation,
> http://jakarta.apache.org/ -
> > >on AIX 4.3.3 with IBM's Java 1.2.2?

> > >I've installed IBM's latest version of Java 1.2.2 (java full
version
> > >"J2RE 1.2.2 IBM build ca122-20000420") on AIX 4.3.3 (maintenance
> level 2
> > >containing all the fixes noted in the Java 1.2.2 README.html),
> fetched
> > >the binary version of Tomcat 3.1. But when I try to start Tomcat,
it
> > >just coredumps.

> > >Any ideas would be greatly appreciated
> > >++Markus

>______________________________________________________________________
> > >Dr. Markus Zahn, Universit=E4t Augsburg, Rechenzentrum, D-86135
> Augsburg
> > >Tel./Fax: ...................................... (0821) 598-2004/-
> 2028
> > >World Wide Web: ....................... http://www.RZ.Uni-
> Augsburg.DE/

> Sent via Deja.com http://www.deja.com/
> Before you buy.

Sent via Deja.com http://www.deja.com/
Before you buy.