Running a script with sendmail problem!

Running a script with sendmail problem!

Post by Leslie Ma » Sat, 10 Jul 1999 04:00:00



Hi all,
    I have a script to start some process. It work fine when redrected
output to a file but it stoped and wait a long time when redirect to mail. I
run it like this

./myscript >myscript.log and
./myscript | mail root

Can anyone help me?
antony

 
 
 

1. Running perl script as sendmail autoresponder

Hello,

I am getting the following error from sendmail set up for autoresponse

sh: perl not available for sendmail programs
554 "|/usr/bin/perl /home/httpd/cgi-bin/mdpro/aaauto.pl"... Service
unavailable

The aauto/pl script work with other Unixes but not with the RH 6.0 system.
Are there changes that can be made to the sendmail.cf file? I've gone
through the O'Reilly and haven't seen anything in particular.

Any help would be appreciated.

Mark

2. Need Fast Ethernet Card recommendation

3. SUID script running through sendmail

4. Installing FreeBSD on a JAZ disk?

5. Solaris Sendmail "NOQUEUE: low on space...." when sendmail ain't running!

6. 48GB NUMA-Q boots, with major IO-APIC hassles

7. A script to generate sendmail.cf then restart sendmail

8. Pete Goodwin's brain compared to other human brains

9. Problems running a program from sendmail

10. Incomplete output from crontab email: running shell scripts from a perl script

11. How to run .profile to ensure cron runs script?

12. Sendmail Scripting Problem

13. Running scripts using variables in a parent script