OpenSSH3.0.2.1

OpenSSH3.0.2.1

Post by pvb2 » Wed, 06 Feb 2002 22:48:46



Hi,

I'm running an AIX box with O.S.4.3.3 ML08.
I have installed

freeware.openssh.3.0.2.1
freeware.openssl.0.9.6.3
freeware.zlib.1.1.3.2

but...

#/usr/local/bin/sshd -Q
Could not load program /usr/local/bin/sshd:
Symbol resolution failed for sshd because:
        Symbol strsep (number 174) is not exported from dependent
          module /usr/lib/libc.a(shr.o).
Examine .loader section symbols with the 'dump -Tv' command.

and tested also
freeware.openssh-oldlibc.3.0.2.1

sshd work fine, but ssh-agent crash....

#/usr/local/bin/ssh-agent
Could not load program /usr/local/bin/ssh-agent:
Symbol resolution failed for ssh-agent because:
        Symbol setenv (number 116) is not exported from dependent
          module /usr/lib/libc.a(shr.o).
Examine .loader section symbols with the 'dump -Tv' command.

What about these errors on AIX???

Valerio

 
 
 

OpenSSH3.0.2.1

Post by Alberto 'JCN-9000' Varesi » Thu, 07 Feb 2002 01:31:48



> Hi,

> I'm running an AIX box with O.S.4.3.3 ML08.
> I have installed

> freeware.openssh.3.0.2.1
> freeware.openssl.0.9.6.3
> freeware.zlib.1.1.3.2

> but...

> What about these errors on AIX???

From Bull's FAQ:

Q : I downloaded openssh 3.0.2.1 but when running, it fails with :
 Could not load program ssh-keygen:
 Symbol resolution failed for ssh-keygen because:
 Symbol strsep (number 119) is not exported from dependent
 module /usr/lib/libc.a(shr.o).
A : This appears mostly with aix4.3.2 but also with some version of AIX
 4.3.3 because bos.adt.include is not at a latest level : in particular, the
 string.h file does not contain a call to strsep (linked on strtok). So we
 built another package named openssh_oldlibc_aix432-3.0.2.1.exe downloadable
 from OPENSSH directory in "new additions" that is to run from AIX 4.3.2
 to AIX 4.3.3 level 4.3.3.1x included (lower than 4.3.3.25)

Looks like you need to upgrade AIX or downgrade OpenSSH ... :(

BTW freeware.openssh.rte/3.0.2.1  freeware.openssl.rte/0.9.6.3
are running fine on my AIX 4.3.3 ML9

--
 Alberto 'JCN-9000' Varesio     AKA  BlueRider    AIX V4.3 System Support
 EADS-MDTV - Via Goito 51/A    Riding the world   Phone: +39-011-415-8111
 10195 Grugliasco (TO) ITALY   on a Honda CB500    Cell: +39-349-492-4769

--
 Any sufficiently advanced technology is indistinguishable from magic.

 
 
 

1. openssh3.5 for aix

Hi ,

I noticed an AIX patch from Darren Tucker which looked at fixing the
problem of ssh not looking at expired passwords at login time.

I loaded this on my aix machine but it still seems to ignore the
password age. Has anybody managed to get this working ?

2. mount hangs while mounting USB storage device

3. connect to openssh3.4p1 only from linux?

4. SoundBlaster PnP supported yet?

5. OpenSSH3.5p1 vs. Commercial SSH 3.2

6. Can Linux use dual Processor board?

7. openssh3.3p1 + solaris 8

8. unexpected_bus_free from EXB-8500

9. openssh3.7p1 chroot patch not work on solaris 7