Ultrix 4.2/LAT/lpd problem

Ultrix 4.2/LAT/lpd problem

Post by goodw.. » Thu, 19 Sep 1991 01:14:46



Hi, I'm running Ultrix 4.2 on a MicroVAX III and have printers hung off
of terminal servers. There are several queues set up to print to ln03's
via the terminal servers, but they're locking up on me extremely often.

After rebooting, the first job goes to the printer and prints. The
second and subsequent jobs sit in the queue and don't get printed until
I kill and restart lpd, and then go into lpc and start the queues
manually. The terminal servers are set up correctly.

I received a set of patches for LAT and installed them, rebuilt the
kernel and rebooted. They didn't fix the problem.

lpd puts one of these lines in the file for each time I do an "lpc start scrsd"
(/usr/adm/lpd-errs):

/usr/lib/lpd: scrsd: cannot open /dev/tty21: Can't assign requested address

1. Is LAT not disconnecting properly?
2. Is it lpd that has the problem?
3. Do I need the :ct=lat: and :uv=psv1.0: flags as well? Or does uv
have to be             3.1, 4.0, 4.1, 4.2, or psv1.0?

The printcap file for scrsd:

## ln03
scrsd:\
        :af=/usr/spool/lpacct/scrsd:\
        :br#19200:\
        :dn=/usr/lib/lpd:\
        :fc#0177777:\
        :fs#03:\
        :if=/usr/lib/lpdfilters/ln03of:\
        :lf=/usr/adm/lpd-errs:\
        :lp=/dev/tty21:\
        :mc#20:\
        :mx#0:\
        :of=/usr/lib/lpdfilters/ln03of:\
        :op=PORT_4:\
        :pl#66:\
        :pw#80:\
        :rw:\
        :sd=/usr/spool/lpd/scrsd:\
        :sh:\
        :ts=UTS409:\
        :xc#0177777:\
        :xs#044000:

This entry was copied over from when I ran Ultrix versions 3.0, 3.1,
4.0, and 4.1, where it worked fine.

The ttys file (i've also tried std.19200; no difference):

tty21   "/etc/getty T19200"     vt100   off nomodem     # LAT terminal

The rc.local lcp startup:

if [ -f /etc/lcp ];
then
    /etc/lcp -z -r -n UUX -N "none available"
    /etc/lcp -g 1 -m 60
    /etc/lcp -s > /dev/console 2>&1 & echo -n ' lat' > /dev/console

    ## Assign tty's to LAT Printers ##
    /etc/lcp -s -h /dev/tty21,/dev/tty22
    /etc/lcp -v UUX -V "none available"
fi

If anyone has seen or knows of this problem, please reply to me, and
I'll summarize if necessary.

Thanks in advance,

 Scott S. Goodwin


 
 
 

1. problem with tcsh login under Ultrix 4.2 on DS2100

Hi Folks,

I'm new to this newsgroup, so please bear with me if this question has
already been
asked and answered...

I use tcsh (5.19 pl 0 ) on a DECstation 2100 running Ultrix 4.2 and X
windows 11.4 .  I (as
well as another user here) have had a problem with logging in as follows
-- if I have
a .cshrc in my home directory, the login screen WON'T LET ME LOG IN !!
(literally that --
it accepts my login, accepts my password, removes the login screen, and
then gives me the
login screen right back.)  I've had to try the ugly and horrid fix of
placing the .cshrc
somewhere else, and source'ing it from my .login but I still don't know
what went wrong.
This problem exists even if the .cshrc file is empty, so I don't think
it can be the contents
of the file.  The login screen used here is the standard(?) digital
login screen.

Since we *recently* converted to Ultrix 4.2, and to X11R4 from R3, I
don't even know where
the problem might lie.  I used the same tcsh on Ultrix 4.0 and it worked
fine.

I've crossposted to comp.unix.ultrix and comp.unix.shell ......
HALP!!

Sumit
--
 ____  _    _   _    _   _  _____
( ___)( )  ( ) ( \  / ) ( )(__ __)      graphics     h = 803.765.1068
( )__ ( )  ( ) (  \/  ) ( )  ( )        Xwindows     o = 803.777.3765
(___ )( )  ( ) ( )\/( ) ( )  ( )          TeX


2. pointers needed for pppd and printing

3. NFS readdir problem from Ultrix 4.2 to Solaris 2.4

4. Converting MS-Winword-Files to Framemaster-Documents

5. mbufs problem - Decsystem 5000 Ultrix 4.2

6. NFS V2 or V3 in SunOS 5.5/5.5.1

7. Printing problem, Ultrix 4.2, Apple LaserWriter Pro [HELP]

8. 1.6.63 I-NODE PROBLEM??

9. Problems with 4.2 lpd flow control

10. Ultrix LAT info

11. printcap for LN03 (sixel) on LAT, Ultrix

12. Anon FTP on Ultrix 4.2

13. help with ULTRIX 4.2 termcap & HP's