Serial port stuck

Serial port stuck

Post by James H. Thomps » Fri, 09 Dec 1994 14:50:34



We attached a modem to the serial port on our SCO box
and removed the getty startup for /dev/tty1a from
the system startup.

stty 0 </dev/tty1a hangs
any attempt to access the line with Kermit hangs
cu -l/dev/tty1a -x9 produces the following:

    altconn called
    Device Type Direct wanted
    mlock tty1a succeeded
    generic open failed, errno = 13
    device was /dev/tty1a
    getto ret -1
    Connect failed: CAN'T ACCESS DEVICE
    call cleanup(1
    call _mode(0)

The first time we try
ls >/dev/tty1a it makes the lights flash on the modem
and turns on and leaves on DTR, and prints a message
about serial port garbage and possible loose cable.
the second time we try it, it hangs.

An suggestions on where to go next would be much appreciated.

Thanks.
--
Jim

 
 
 

Serial port stuck

Post by hal.. » Sat, 17 Dec 1994 13:16:40



:We attached a modem to the serial port on our SCO box
:and removed the getty startup for /dev/tty1a from
:the system startup.
:
:stty 0 </dev/tty1a hangs
:any attempt to access the line with Kermit hangs
:cu -l/dev/tty1a -x9 produces the following:
:
:    altconn called
:    Device Type Direct wanted
:    mlock tty1a succeeded
:    generic open failed, errno = 13
:    device was /dev/tty1a
:    getto ret -1
:    Connect failed: CAN'T ACCESS DEVICE
:    call cleanup(1
:    call _mode(0)
:
:The first time we try
:ls >/dev/tty1a it makes the lights flash on the modem
:and turns on and leaves on DTR, and prints a message
:about serial port garbage and possible loose cable.
:the second time we try it, it hangs.

If you seek error 13 you find that it is, in effect, forbidden to access it.
What are the permission bits, who owns it?

 
 
 

1. Serial Port stuck at 4,800 baud --- Help!

Dear netters,

I'm using my second serial port (ttyS1) for both a modem (28,800 bps)
and a serial ascii-terminal (4,800 bps) on a 16550 uart according to
setserial(1). Ever since connecting the terminal to the port it is
stuck at 4,800 bps and refuses to talk to the modem at different
speeds when I hook up the modem to it, even under
The-OS-that-shall-not-be-named-here. The modem works great on ttyS0,
though (or its call-out cua0 equivalent), including different speeds.

Can anyone tell me what's wrong?

Thanks in advance for any pointers,

Uwe.

--
Uwe 'hoover' Schuerkamp =================================================  

http://dim.chemie.uni-bielefeld.de/~hoover========Fax:   +49-5221-185-272
=========================================================================

2. Reading is much more interesting than TV (0020/1704)

3. serial port stuck!

4. failed dependencies in kde2

5. Serial port stuck at 7-bits in cu - continued

6. installing parallel printer on Sparcstation LX

7. stuck serial ports and tip

8. Status query on P90

9. Serial ports 'stuck' on a Sun Fire 280

10. Q: Using Stick parity on serial ports

11. serial port on v490 and Serial port on StorEdge 3510

12. Serial port to serial port copying software

13. Send traffic from one serial port out to another serial port