Can't get to No Windows mode in VUE

Can't get to No Windows mode in VUE

Post by Chris Fab » Sat, 22 Jun 1996 04:00:00



I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
logout of my session, and then go to the "No Windows" option, VUE exits,
but then says:

getty: failed to open /dev/tty: No such device or address.

This doesn't make a lot of sense, isn't tty the device for the monitor,
which otherwise works just fine.  I"m starting VUE from the rc file.  I've
tried logging into the console as root, starting vue, and then going to No
Windows, but that doesn't work right either.  I've always this problem,
even after reinstalling the whole system. I'm running VUE 3.0 and HP-UX
9.05.  I don't want to have the possibility of someone logging out of vue
and getting root access, which is the main reason I'm actually worrying
about this.  Thanks.  chris.

Chris Fabri                                    Network Services Group

              "Candy knows no religion."  - E.G. Perlman

 
 
 

Can't get to No Windows mode in VUE

Post by Scott Wooda » Sun, 23 Jun 1996 04:00:00



Fabri) writes:
> I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
> logout of my session, and then go to the "No Windows" option, VUE exits,
> but then says:

> getty: failed to open /dev/tty: No such device or address.

> This doesn't make a lot of sense, isn't tty the device for the monitor,
> which otherwise works just fine.  I"m starting VUE from the rc file.  I've
> tried logging into the console as root, starting vue, and then going to No
> Windows, but that doesn't work right either.  I've always this problem,
> even after reinstalling the whole system. I'm running VUE 3.0 and HP-UX
> 9.05.  I don't want to have the possibility of someone logging out of vue
> and getting root access, which is the main reason I'm actually worrying
> about this.  Thanks.  chris.

> Chris Fabri                                    Network Services Group

> http://bohica.nsg.nwu.edu/~fabric/cmf                   (847)467-6387

>               "Candy knows no religion."  - E.G. Perlman

You do not mention what hardware you are running on. HP had this problem with
Vue at one time. It came back and still exists in 9.10 on Series 300 boxes.
On Series 700 boxes, however the problem has been cleared up. Perhaps you need
to apply the latest Vue patches, available from HP via the internet.

I don't really understand your worry about logging out of Vue and gaining root
access.  Once the root account has established a password, it will always
require a password for access in either Vue or console mode.  Hope this helps.
Feel free to write back if you have further questions.

--
Scott Woodard


 
 
 

Can't get to No Windows mode in VUE

Post by Scott Wooda » Sun, 23 Jun 1996 04:00:00



Quote:Fabri) writes:
> I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
> logout of my session, and then go to the "No Windows" option, VUE exits,
> but then says:

> getty: failed to open /dev/tty: No such device or address.

> This doesn't make a lot of sense, isn't tty the device for the monitor,
> which otherwise works just fine.  I"m starting VUE from the rc file.  I've
> tried logging into the console as root, starting vue, and then going to No
> Windows, but that doesn't work right either.  I've always this problem,
> even after reinstalling the whole system. I'm running VUE 3.0 and HP-UX
> 9.05.  I don't want to have the possibility of someone logging out of vue
> and getting root access, which is the main reason I'm actually worrying
> about this.  Thanks.  chris.

One further note:  If the problem is indeed Vue related, then while logged into
Vue as root type:

        init 2; exit

from a hpterm and Vue will be shut down, taking you to console mode, run level 2.

If you indeed have a console device problem instead, this may leave you without
access to the system, and your only recourse will be to re-cycle power... but
you will then know where the problem lies.  Since you have re-installed, I
highly suspect that the problem resides in Vue and a patch can fix this.
--
Scott Woodard

 
 
 

Can't get to No Windows mode in VUE

Post by Aaron R. Kulki » Tue, 25 Jun 1996 04:00:00




>I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
>logout of my session, and then go to the "No Windows" option, VUE exits,
>but then says:

>getty: failed to open /dev/tty: No such device or address.

>This doesn't make a lot of sense, isn't tty the device for the monitor,
>which otherwise works just fine.  I"m starting VUE from the rc file.  I've

                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

That might be where the problem is...try starting it from /etc/inittab.
in /etc/inittab, your FIRST line should be:

init:3:initdefault

and then later, you should have this line:

vue :34:respawn:/etc/vuerc                # VUE validation and invocation

Quote:>tried logging into the console as root, starting vue, and then going to No
>Windows, but that doesn't work right either.  I've always this problem,
>even after reinstalling the whole system. I'm running VUE 3.0 and HP-UX
>9.05.  I don't want to have the possibility of someone logging out of vue
>and getting root access, which is the main reason I'm actually worrying
>about this.  Thanks. chris

Don't worry about that...they still need to root password.....VUE or no VUE.
--

Unix Systems Administrator
EDS/GM Powertrain
GM Warren Technical Center
Warren, Michigan, USA

---------------------------------------------------------------------
Have you smoke-tested your (pick one:cpu/hard-drive/power-supply) today?
---------------------------------------------------------------------
There are 2 Kinds of planes: Fighters, and targets.
There are 2 Kinds of boats: Submarines, and targets.
There are 2 Kinds of 4x4's: Jeeps and SOB's (Some other brand)
There are 2 Kinds of O/S's: Unix, and brain-farts.
---------------------------------------------------------------------
-----BEGIN GEEK CODE BLOCK-----
Version: 3.1
GE(GAT)d+(-) s:- a30 C+++$:() UHI++++$>BL P!>+++ L++ !E- W+(-)$ N++ o K?
w--- !0 !M-(--) V-- PS+,-- PE++() Y+>++ PGP>++ !t !5 !X !R tv-->---
b++1/2 DI+++ D G e*>++++ h>--- r* y?
------END GEEK CODE BLOCK------

 
 
 

Can't get to No Windows mode in VUE

Post by Chris Fab » Tue, 25 Jun 1996 04:00:00



> Fabri) writes:
> > I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
> > logout of my session, and then go to the "No Windows" option, VUE exits,
> > but then says:

> > getty: failed to open /dev/tty: No such device or address.

> > This doesn't make a lot of sense, isn't tty the device for the monitor,
> > which otherwise works just fine.  I"m starting VUE from the rc file.  I've
> > tried logging into the console as root, starting vue, and then going to No
> > Windows, but that doesn't work right either.  I've always this problem,
> > even after reinstalling the whole system. I'm running VUE 3.0 and HP-UX
> > 9.05.  I don't want to have the possibility of someone logging out of vue
> > and getting root access, which is the main reason I'm actually worrying
> > about this.  Thanks.  chris.


> One further note:  If the problem is indeed Vue related, then while
logged into
> Vue as root type:

>         init 2; exit

> from a hpterm and Vue will be shut down, taking you to console mode, run
level 2.

This doesn't work, it just exits the hpterm.

I am using a 700, and I've installed the most recent runtime patch, but it
still hasn't worked.  I'm seeing if there is some other patch which covers
this.  

The problem I'm having is that if I'm logged on as root and exit vue, root
access *can* be gained without entering another password.  What happens is
it exits view and says "wait for login prompt"  Maybe i"m just impatient,
but after about 30 seconds nothing has happened, so I try hitting
control-C, and it brings me to the prompt, and have root access.  Not
cool.  I don't understand why this isn't working, and it would seem like a
patch would fix it.   Any more ideas?

Chris Fabri                                   Northwestern University                

 
 
 

Can't get to No Windows mode in VUE

Post by Dr A O V Le Bla » Wed, 26 Jun 1996 04:00:00



> I'm having a problem going to "No Windows" mode in HP-VUE.  Whenever I
> logout of my session, and then go to the "No Windows" option, VUE exits,
> but then says:

> getty: failed to open /dev/tty: No such device or address.
...
>I am using a 700, and I've installed the most recent runtime patch, but it
>still hasn't worked.  I'm seeing if there is some other patch which covers
>this.  

We have had this problem in Manchester with HP-UX 9.01 and 9.03 for years.
In our setup, VUE is started from inittab.  The 'no windows' option
works once after starting VUE, but never again.  Doing

     init 2
     init 3

allows you to have one more 'no windows' session, but has the disadvantage
of killing all X terminals using the system.  We also have a problem
under some circumstances with VUE being unable to restart after someone
logs out.  This appears to happen when any process still running at
that time has /dev/console as its controlling tty.  I've given up on
this one.  After reporting it a dozen times to HP and installing
countless patches, I suspect this is one of those problems which
(like the rpc.lock with NFS) will never get properly solved, at least
not in this release.  Maybe 10 will fix it.

     -- Owen

 
 
 

1. Changing Serial Nos using 'brand'

Hi all,

I'm involved in using one machine to install SCO unix on hot swappable
disks. In order to do this I need change the serial number of a machine
so that each machine can have a unique ID. The disk will then be
installed on a new machine and the serial number will identify the
machine with the serial ID.

What are the files that need to be "brand"ed in order to change the
serial number/activation key pairing ?
Tried files in /etc/perms plus /etc/perms/bundle to no avail.
Using "uname -X" to see current serial number - is this the correct
command?

I'd appreciate if someone could get back to me on this one ...

Thanks in advance ...

Ray Fallon

Address : Nortel Ireland Ltd.,
Galway, Ireland.

2. domain appended to nslookup's?

3. Getting XLock 'swirl' mode working:

4. how to verify a dump tape?

5. getting 'vi' mode

6. CDROM on Sparc-5 is not working

7. What's 'side effects' of Ksh built-ins?

8. No /bin/test --- Solaris 2.x != SVR4 ?

9. It's not bad canned meat...

10. Getting out from the X windows system totally to terminal mode - newbie

11. Can ISP detect when dial-ins are 'overloaded' ?

12. how do 'plug-ins' work?