problems with gprof (1) on SunOS 4.1.1

problems with gprof (1) on SunOS 4.1.1

Post by Johan Tho » Wed, 03 Jun 1992 23:51:26



After Reading The Manual and trying various things, i am still
in problems using prof(1) and gprof(1).

When i compile my code using the -p or -pg flag, ld says:

ld: Undefined symbol
   mcount

So i think i will have to link my code with some library, but i
don't know which one.

Can someone please enlighten me?

Please email and i'll summarize.

Thanks in advance,

Johan.
--
--------------------------------------------------------------------------------

University of Limburg               |
Dept. of computer science           | #include <std/disclaimer.h>

 
 
 

problems with gprof (1) on SunOS 4.1.1

Post by Johan Tho » Thu, 04 Jun 1992 00:55:51


Oops,

i looked once again and saw that i didn't supply the -pg or -p option to
the linker.

After correcting my makefile everything worked fine.

Sorry,

Johan.
--
--------------------------------------------------------------------------------

University of Limburg               |
Dept. of computer science           | #include <std/disclaimer.h>

 
 
 

1. STL map problem on sunOS 5.7, not on sunOS 5.8

I am experiencing a problem in which a hang is occurring while trying
to find a key in a stl map (it is never reaching the null at the end
of the map). When I run the code on a sparc machine with version 5.8
it runs fine. When I run it on 5.7 a hang occurrs. It does not matter
which version I compile on. Has anyone experienced anything like this,
or have any suggestions.

2. RH 6.0 pump not getting IP via DHCP from Cisco 675

3. Problem with gprof

4. Microsoft the hypocrite on GPL License: SFU 3.0 includes Interix

5. gprof linking problem

6. tcpdump packet matcher broken

7. Problems with gprof/prof on Solaris 2.2

8. Solaris 2.4 named: rt_malloc errors

9. problems with ddd,xxgdb and gprof

10. a problem on gprof.

11. Problem using prof/gprof - _mcount undefined.

12. gprof and profiling problem

13. gprof problem