termcap problem: no colors on xterm!!

termcap problem: no colors on xterm!!

Post by Luis A. Burgo » Thu, 02 Sep 1999 04:00:00



Hello guys!

I'm experiencing a problem: when I run  anything inside and xterm
(/stand/sysinstall) it appears black and white.  I thougth it was the way it
was, but one day I ran the Redhat Linus setup thru sshd, which emulates
xterm and when ran /usr/sbin/setup, it showed up colorful. Immediately tried
Midnight commander,: B/W under FreeBSD, color under Linux.

Decided to try under X. Run X server, KDE, ran xterm: Black and white. Did
the same thing under linux, color.

I checked the /etc/termcap but to be honets, didn't understand much about
it. Compared it to the linux termcap and they were different. The linux
termcap includes a co#80 entry for xterm, and FreeBSD's doesn't. I tried
adding it, didn't work.

Does anybody can help me fixing that?

Thanks in advance,

Luis

 
 
 

termcap problem: no colors on xterm!!

Post by Marc Fonvieil » Thu, 02 Sep 1999 04:00:00



Quote:>Hello guys!

>I'm experiencing a problem: when I run  anything inside and xterm
>(/stand/sysinstall) it appears black and white.  I thougth it was the way it
>was, but one day I ran the Redhat Linus setup thru sshd, which emulates
>xterm and when ran /usr/sbin/setup, it showed up colorful. Immediately tried
>Midnight commander,: B/W under FreeBSD, color under Linux.

>Decided to try under X. Run X server, KDE, ran xterm: Black and white. Did
>the same thing under linux, color.

check TERM variable it must be xterm-color to have colors.

If you want an rxvt with colors, put in your .Xdefaults this kind of
line:
rxvt.termName:  xterm-color

Marc

 
 
 

termcap problem: no colors on xterm!!

Post by T.E.Dicke » Fri, 03 Sep 1999 04:00:00



Quote:> I'm experiencing a problem: when I run  anything inside and xterm
> (/stand/sysinstall) it appears black and white.  I thougth it was the way it
> was, but one day I ran the Redhat Linus setup thru sshd, which emulates
> xterm and when ran /usr/sbin/setup, it showed up colorful. Immediately tried
> Midnight commander,: B/W under FreeBSD, color under Linux.
> Decided to try under X. Run X server, KDE, ran xterm: Black and white. Did
> the same thing under linux, color.
> I checked the /etc/termcap but to be honets, didn't understand much about
> it. Compared it to the linux termcap and they were different. The linux
> termcap includes a co#80 entry for xterm, and FreeBSD's doesn't. I tried

co#80 is "80 columns" (some postings I've seen today indicate that FreeBSD
has manpages for termcap, though iirc they are rather skimpy - you'd do
better by reading the terminfo manpage in ncurses ;-)

Quote:> adding it, didn't work.

The termcap entry that comes with XFree86 xterm does color (though I have
observed that it's not integrated with the FreeBSD release).

The XFree86 3.3.3.1 xterm supports ANSI color and VT220 emulation
There's an faq at
        http://www.veryComputer.com/
        ftp://ftp.clark.net/pub/dickey/xterm

--
Thomas E.*ey

http://www.veryComputer.com/

 
 
 

termcap problem: no colors on xterm!!

Post by S.W.Drinkar » Sun, 05 Sep 1999 04:00:00


Just did an install of XFree 3.3.5.  There are specific termcap entries
that have to be edited to enable a color xterm.  Check the docs if you
have a late-date X version.

Sam

 
 
 

1. xterm/telnet/TERMCAP/window size/editor problem

Hi Folks:

        I'm having a frustrating problem editing on one of our SUNs.
From my own SUN, I have no problems creating an xterm, telnet-ing,
and editing on an Alpha/OSF1, an RS/6000 AIX, and on a VAX/UNIX box.
But on this one SUN that I telnet to, the TERMCAP doesn't seem to be
right.  When I get into vi, it's off by a few lines.  I can't see the
first few, and doing ":set all" shows a "window" size about 5 greater
than my xterm window size.  The "more" command can't scroll properly
either.  I've been poking around the system and man pages, but I don't
have a clue yet as to how to solve this problem.  The person who has
it on his desk says emacs doesn't even work right locally.
All helpful comments would be greatly appreciated.

Thanks a bunch,
Wayne
--
----------------------------------------------

I'm just a soul whose intentions are good,
Oh Lord, please don't let me be misunderstood.

2. Need a phone-network solution for IP and IPX....

3. are SLS 1.01 xterms color xterms?

4. JFAIL with lpq

5. SOLUTION - xterm/telnet/TERMCAP/window size/editor problem

6. C-language problem

7. xterm instead of xterm-color in RH4.0 / MetroX

8. Netscape Communicator

9. xterm or color-xterm?

10. Color xterm has no color

11. color ls in xterm colors

12. Change cr, bg, and fg colors in a color xterm?

13. My Color xterm just won't display color, help.