ssh/emacs 19.34 on Solaris/XF863.2A combo kills X server

ssh/emacs 19.34 on Solaris/XF863.2A combo kills X server

Post by Jari Kokk » Tue, 15 Apr 1997 04:00:00



Anyone else seen this?

Whenever I start emacs 19.34 on a Solaris 2.5 host using X port forwarding
with ssh 1.2.19, my X server (XFree SVGA 3.2A) dies with out of swap space.
The same combo, but the emacs on other platforms works Just Fine.

I am running FreeBSD 2.1.7

Jari

 
 
 

1. Problems compiling emacs 19.34 on Solaris 2.6

hi, i'm trying to compile emacs on Solaris 2.6 (having never been
happy with "package" releases)

anyway, following the directions included with the package, i ran the
configure script with these options

# ./configure sparc-sun-solaris2.6 --with-gcc --with-x=no

and everything went fine. the makefile was sucessfully built. the next
step should be 'make', but this is where things fail. the output is
below. has anyone figured out why this doesn't work?

# /usr/ccs/bin/make
Producing `src/paths.h' from `src/paths.in'.
src/paths.h is unchanged
cd lib-src; make all  \
  CC='gcc' CFLAGS='-g -O' CPPFLAGS='' \
  LDFLAGS='' MAKE='make'
gcc -DHAVE_CONFIG_H    -I. -I../src -I/downloads/emacs-19.34/lib-src
-I/downloads/emacs-19.34/lib-src/../src   -g -O
/downloads/emacs-19.34/lib-src/profile.c -lsocket -lnsl -lelf -lkvm -o
profile
/downloads/emacs-19.34/lib-src/profile.c: In function `gettimeofday':
/downloads/emacs-19.34/lib-src/profile.c:71: argument `tzp' doesn't
match prototype
/usr/include/sys/time.h:389: prototype declaration
*** Error code 1
make: Fatal error: Command failed for target `profile'
Current working directory /downloads/emacs-19.34/lib-src
*** Error code 1
make: Fatal error: Command failed for target `lib-src'

--

( =--
 Ben                               |     :Speed:

 http://www.skidmore.edu/~brunning | .FlyingSaucers.
 - How to screw with a Macintosh: www.machacks.com -
                                                --= )

--

( =--
 Ben                               |     :Speed:

 http://www.skidmore.edu/~brunning | .FlyingSaucers.
 - How to screw with a Macintosh: www.machacks.com -
                                                --= )

2. where can I buy g3/g4 mobos?

3. Emacs 19.34

4. pppd v2.5.x "protocol reject for unsupported protocol"

5. RedHat's Emacs 19.34: h_errno_ problem

6. XF86Config problem

7. A problem installing emacs 19.34

8. Warning message

9. Emacs 19.34 on linux 2.2.15

10. emacs 19.34 and FBSD 4.0

11. networking problem with emacs 19.34, RH 4.2, AFS

12. emacs 19.34, gmalloc and hpux 10.20

13. compiling emacs 19.34 on glibc2 Linux machines