PPPD Dial-In, FreeBSD 4.3, "LCP: timeout sending Config-Requests".

PPPD Dial-In, FreeBSD 4.3, "LCP: timeout sending Config-Requests".

Post by jeebu » Wed, 17 Jul 2002 17:17:14



Hi, Ive setup pppd to accept dialins on FreeBSD 4.3,
this is what i got in /var/log/messages when people try to connect:

Jul 15 21:42:19 e-l33t pppd[25891]: Connect: ppp0 <--> /dev/ttyd0
Jul 15 21:42:49 e-l33t pppd[25891]: LCP: timeout sending Config-Requests
Jul 15 21:42:49 e-l33t pppd[25891]: Connection terminated, connected for 1
minutes

now , I read somewhere that this could have something to do with gre
stealing the lcp packets,
 but i'm sure i didnt compile gre into my kernel.

( Also, I set the modem to ATS0=1 and saved it with AT&W0 , so it auto
answers, and this works fine )

# cat options
            ms-dns 192.168.0.2
            domain lamenet.org.au
            lock
            proxyarp
            crtscts
            115200
            modem
            +pap
            lcp-max-configure 40 // recently added, not tested
#
# cat pap-secrets
# Secrets for authentication using PAP
# client        server  secret          acceptable local IP addresses
  dialin        *       "password"        *
#
# cat options.ttyd0
192.168.0.7:192.168.0.8 # ip's of local and remote hosts

# cat options.ttyd1
192.168.0.7:192.168.0.8 # ip's of local and remote hosts
#

And in /etc/ttys

# cat /etc/ttys | grep ppp
ttyd0   "/usr/sbin/pppd"                dialup  on  secure
ttyd1   "/usr/sbin/pppd"                dialup  on  secure
#

Thanks :)

 
 
 

1. pppd dial ins and , "LCP: timeout sending Config-Requests"

Hi, Ive setup pppd to accept dialins on FreeBSD 4.3,
this is what i got in /var/log/messages when people try to connect:

Jul 15 21:42:19 e-l33t pppd[25891]: Connect: ppp0 <--> /dev/ttyd0
Jul 15 21:42:49 e-l33t pppd[25891]: LCP: timeout sending Config-Requests
Jul 15 21:42:49 e-l33t pppd[25891]: Connection terminated, connected for 1
minutes

now , I read somewhere that this could have something to do with gre
stealing the lcp packets,
 but i'm sure i didnt compile gre into my kernel.

( Also, I set the modem to ATS0=1 and saved it with AT&W0 , so it auto
answers, and this works fine )

# cat options
            ms-dns 192.168.0.2
            domain lamenet.org.au
            lock
            proxyarp
            crtscts
            115200
            modem
            +pap
            lcp-max-configure 40 // recently added, not tested
#
# cat pap-secrets
# Secrets for authentication using PAP
# client        server  secret          acceptable local IP addresses
  dialin        *       "password"        *
#
# cat options.ttyd0
192.168.0.7:192.168.0.8 # ip's of local and remote hosts

# cat options.ttyd1
192.168.0.7:192.168.0.8 # ip's of local and remote hosts
#

And in /etc/ttys

# cat /etc/ttys | grep ppp
ttyd0   "/usr/sbin/pppd"                dialup  on  secure
ttyd1   "/usr/sbin/pppd"                dialup  on  secure
#

Thanks :)

2. Data type 9 error

3. "LCP: timeout sending Config-Requests" w/ pppd 2.1 p2

4. GNU Emacs: Has anybody ported it to the RS/6000?

5. pppd: "LCP: timeout sending Config-Requests"

6. rh 5.1 installation Partition

7. PPPD says: "LCP: timeout sending Config-Requests"

8. The ongoing http://domainname.com problem

9. Rehat 4.0 ppp: "LCP: timeout sending Config-Requests"

10. "LCP: timeout sending Config-Requests" --- whose fault?

11. ppp fails "LCP: timeout sending Config-Requests"

12. "LCP: timeout sending Config-Requests" Problem????

13. pppd fails with: LCP: timeout sending Config-Requests