where is _main in locore.s?

where is _main in locore.s?

Post by zhihuizha » Sun, 12 Apr 1998 04:00:00



Could anybody just tell me where is the _main called in file locore.s.
I can not find it in the same directory.  Better, also tell me which
makefile specifies this stuff.  

Thanks a lot.

--
-------------------------------------------------

Zhihui Zhang
100 Roberts Street, Apt #21-6
Binghamton, NY 13901, U.S.A

Web Site: http://cs.binghamton.edu/~zzhang

-------------------------------------------------

 
 
 

where is _main in locore.s?

Post by Dan Nelso » Mon, 13 Apr 1998 04:00:00



> Could anybody just tell me where is the _main called in file
> locore.s. I can not find it in the same directory.  Better, also tell
> me which makefile specifies this stuff.

> Thanks a lot.

It's in /sys/kern/init_main.c

 
 
 

1. Disk Crash - Cannot compile - error: undefined reference to `_main

I just had a minor disk crash and now when I try to compile any programs I
get:

%  # make
%  cc -O2 -o mpage mp_main.o mp_glob.o mp_text.o mp_post.o mp_file.o mp_page.o
%  mp_args.o
%  mp_main.o(.text+0xf7): undefined reference to `_main'
%  make: *** [mpage] Error 1

Does anyone know what might have been trashed?  Suggestions would really be
appreciated.      :-)

All the best to everyone this holiday season!

--

  ----------------------------------------------------------------------
  FREE ACCESS TO E-MAIL & NEWS at +1 604 681 0670.  INFO on Environment,
  Science, Medicine, AIDS, Native (Indigenous) Issues and more.  We sell
  ZyXEL, Penril, Telebit and more world-wide to support this Free Public

  ----------------------------------------------------------------------

2. Apache and Oracle Web Agent

3. How to define the _main symbol for crt0.o?

4. IP adddress change

5. _main() : Does anybody know what this is ... ??

6. Win95-like scrollbar for Linux/X

7. "_main()" in HPUX's libCsup

8. problem with NAT and proxy-ARP

9. gcc giving error _main (multiply defined) /usr/lib/crt0.o

10. This clone thing...am I stupid, or am I right?

11. I am with the following error, when i am running lilo...

12. Am I touchy? Or am I right?