Boot Problems

Boot Problems

Post by sona » Fri, 31 Dec 1999 04:00:00



I recently installed FreeBSD 3.3 and when I reboot it gives me to
options
F1 for DOS
F5 for FreeBSD

when I press F1 it boots fine to win2k
but when I press F5 for freebsd
a blank screen comes up and says
'PRESS ANY KEY TO REBOOT'

any ideas? thanks

 
 
 

Boot Problems

Post by sona » Fri, 31 Dec 1999 04:00:00


I forgot to mention that I have 3 different IDE drives
1st drive is fat32
2nd drive is fat32
3rd drive is freebsd

if that helps at all ;)
thanks

 
 
 

1. dual-HD, dual-boot problem ... booting Win98 fails on hdb

I put one harddisk in my computer and installed Mandrake7.2.  I then
popped this disk out, popped a new disk in, and installed Windoze 98
on it. I then made this disk the slave (hdb) and put back in my
Mandrake disk as hda, and then booted into Linux (using grub).
Mandrake recognizes my /dev/hdb when I mount it automatically as
/mnt/win98. So, the problem I'm about to describe doesn't seem to be a
problem with the harddisk, slave setting, etc.

I then used DrakConf to change my grub configuration so that it
associated win98 with /dev/hdb1. I then tried rebooting, booting linux
through grub still works fine, but when I choose win98 through grub, I
got the following error:

Booting 'win98'
root(hd1,0)
Error: selected disk does not exist.

I assume that this error is related to the fact that when win98 was
installed on hdb, it was actually hda at the time.  Now it's confused
b/c it's hdb. ??  (said another way: I think the problem is confusion
over the fact that windows was originally installed when that disk was
hda, but now it's hdb.)

I recently read (somewhere on usenet) the following suggestion:

the "map" command under GRUB would trick this second drive (hd1) to
think
that it owned the first partiition, thereby allowing it to dual boot.

#################################
# /boot/grub/menu.lst - generated by Lizard

*** Linux lines cut out to save space

# for booting Windows 98

title  = win98
root  = (hd1,0)
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
###################################

So, I tried this, but not knowing anything about grub, I
think I used the grub command to install it incorrectly,
because when I tried to reboot, grub failed to work properly
at all, and I had to boot with my boot floppy.

So, how can I solve this? Is the grub map approach the
right direction? If so, how do I do it correctly (e.g.,
what do I need to type on the command line after editing
the menu.lst file?)

If not, is there another way. I had a similar problem a couple
of years ago, and someone suggested that I use a program
(which I don't remember the name of) that allowed me to
go in and (I believe) edit the master boot record on my
windows hard drive to tell it that it was now the hdb
drive. I did that successfully that time. Should I try
that again, and if so, what's the program called that
allows me to edit it?

Sent via Deja.com
http://www.deja.com/

2. Connected via ethernet, setting up linux to allow a "dial in"

3. Lilo boot problem: doesn't boot dos (invalid media type)

4. changing colour depth in X, how?

5. Slackware Boot Disks booting problems

6. Serial comms - How to force RTS and DTR high and low ??

7. Boot problem of the 2nd disk: defective boot record

8. Write protect windows mount

9. booting problems: linux dual boot

10. 2.2-GAMMA-0225 boot floppy causing boot problem

11. Win95 boot problems on multi-boot LILO system

12. NT/LIINUX dual boot problem: NT boot failed

13. boot problem with boot floppy