Can't Get Sony CDU33A CD-ROM to Work

Can't Get Sony CDU33A CD-ROM to Work

Post by P?l Hermstad Kristense » Sat, 08 Aug 1998 04:00:00



I cant't get my Sony CDU33A to work with release 2.2.6. The CD-ROM is
connected to a Sound Blaster 16 card, and uses address 0x230. The device
is either not found, or I get an error message telling me that the CD
looks more like an Audio CD than the FreeBSD distribution. Now, FreeBSD
IS sweet music, but... :-)

Does anybody have a solution?

Thanks!

Paal

 
 
 

Can't Get Sony CDU33A CD-ROM to Work

Post by Daniel T » Wed, 12 Aug 1998 04:00:00



Quote:>I cant't get my Sony CDU33A to work with release 2.2.6. The CD-ROM is
>connected to a Sound Blaster 16 card, and uses address 0x230. The device
>is either not found, or I get an error message telling me that the CD
>looks more like an Audio CD than the FreeBSD distribution. Now, FreeBSD
>IS sweet music, but... :-)

        I have used a CDU33A with the Sony propriety interface card under
FreeBSD just fine. So I presume your problem is in the difference between
a real Sony interface, and your SB16 which I presume to be a MCD(?), i.e.
the old SB16 that come out after the CR563-exclusive SB16's but before
the IDE/PnP SB16's. It was called the SB16 MultiCD I think and the only
one I know of that could take a Sony CDROM.
        Anyways, the real Sony interface has several jumpers to set
IRQ as well as address. If you still can't get it to work, people on ebay
are selling either the CR563 or an interface card that supposedly works
with the Sony, either for about $10-15. Of course it may make more sense
to buy a 4x-16X IDE CDROM for $20-25.

Cheers,
Dan Ts'o, 212-327-7671, FAX: 212-327-7671
The Rockefeller University, 1230 York Ave.  Box 138
New York, NY  10021


 
 
 

1. Linux still can't detec Sony cdu33a CD-Rom driver

Hi, there,

I am trying to make my Sony cdu33a cd-rom driver work under Linux.
The cd-rom driver is attached to soundblaster 16 soundcard and works
fine under dos/windows with 2 ide hard drive.
I use kernel 1.2.9 and configure kernel with cdu31a driver and iso9660
filesystem support and have symbolic link /dev/cdrom to /dev/cdu31a.
I have run the MAKEDEV.ide1 shell script file and put kernel command
hdc=cdrom
append = "cdu31a=0x230,0," (also tried "append=cdu31a=0x230,0,")
in lilo.conf file.
(I have tried also boot to DOS then insert bootdisk to boot to Linux)
The cdrom driver still can't be detected at the boot time.
The cdu31a device driver exists with right major and minor number,
and doing cat /proc/filesystems indicate the presence of iso9660
filesystem. However doing cat /proc/devices does not show the presence
of cdu31a cdrom device driver.

Please help !!!
Any help, solutions or suggestions will be greatly appriciated.

Youcheng Zhang
Dept. Oceanography, TAMU

2. 2 x RTL 8139 Cards = doesn't work

3. Opti929s sound card & Sony CDU33A Cd-Rom

4. Here's a Zinger for the true linux Wizard.

5. Sony CDU33A CD-ROM install problem

6. lpsched error message

7. HELP! Sony CDU33a CD-ROM

8. Summary: trick of adding a dumb terminal

9. WTB: Linux Cd-rom for my Sony CDU33a

10. recognizing the Sony CDU33A CD-ROM drive...

11. Help needed mounting Sony CDU33a CD-ROM

12. Problems detecting Sony CDU33A CD-ROM drive