GTK guru -> program crashes complaining about gtk.......

GTK guru -> program crashes complaining about gtk.......

Post by Courtney Thoma » Sat, 19 Jan 2002 04:58:25



Must I do more than install gtk12 from the ports to be able to install
Netscape-6.2, as far as gtk is concerned ?

That is, must I also install other gtk-related ports such as
gtk-engines, to render gtk fully functional ?

I realize that this relates to what a program is attempting, but my
question is.....is gtk12 fully functional or is it part of a suite that
must be installed to provide "typical" gtk functionality ?

I'm getting a gtk related error on Netscape install attempt........

        Gtk-CRITICAL     **: FILE GTKWIDGET.C: LINE 1510
        (gtk_widget_hide): assertion `widget != NULL' failed.
        Segmentation fault - core dumped.

Appreciatively,
Courtney

 
 
 

GTK guru -> program crashes complaining about gtk.......

Post by Steve O'Hara-Smit » Sat, 19 Jan 2002 06:38:34


On Thu, 17 Jan 2002 19:58:25 GMT

CT> Must I do more than install gtk12 from the ports to be able to install
CT> Netscape-6.2, as far as gtk is concerned ?

        That would be a Linux binary I presume. If so you will need to
install the linux-gtk port, you may have an old one.

--
C:>WIN                                          |     Directable Mirrors
The computer obeys and wins.                    |A Better Way To Focus The Sun
You lose and Bill collects.                     |  licenses available - see:
                                                |   http://www.sohara.org/

 
 
 

GTK guru -> program crashes complaining about gtk.......

Post by Courtney Thoma » Tue, 22 Jan 2002 07:49:01


Thank you for your kind reply.

I'm inexperience wrestling with ports and would much appreciate a
comment on this error msg's consequences.........

./netscape-installer-bin:
/usr/compat/linux/lib/libc.so.6: version 'GLIBC_2.2.3' not found
(required by /usr/compat/linux/lib/libgtk-1.2.so.0)

I guess the netscape installer found libc.so.6 but didn't like the
version. If yes,....

1-do I need to upgrade glibc* ?

2-is this located in ports, if yes, where ?

3-if after upgrading, netscape still dislikes the version, the what ?

4-since I apparently already have a C compiler of some sort installed
since I've been able to compile "stuff" in the past, is glibc* a library
  for a C compiler ? and does this mean my compiler's OK but the
library's not ?

5-I have located/downloaded glibc-2.2.4.tar.gz [16+ MB], should I
install this ? If yes, how, without trashing what's already installed,
please ? Will this solve my problem, for it is actually the latest not
the one sought ?

I realize that you didn't adopt me :-) just because you were kind enough
to reply before, but it's a bit overwhelming at the moment. If you don't
have time to guide me through this maze, a URL would be helpful.

Appreciatively,
Courtney


> On Thu, 17 Jan 2002 19:58:25 GMT

> CT> Must I do more than install gtk12 from the ports to be able to install
> CT> Netscape-6.2, as far as gtk is concerned ?

>    That would be a Linux binary I presume. If so you will need to
> install the linux-gtk port, you may have an old one.