getty+ppp : doesn't spawn ppp :-(

getty+ppp : doesn't spawn ppp :-(

Post by Jean Frederic FARN » Sat, 17 Jul 1999 04:00:00



Hi,

I configured a FreBSD 2.2.8 box with a USR modem on 'COM1'
Modem works fine for outdialing, cable's OK, conf seems OK (see at the
end of this post...)
Modem can recieve call and takes the line...then getty starts to move to
the top of the process (watching it with /usr/bin/top)

The I use a G3 PowerMacintosh laptop with Remote Access (works fine with
my ISP)...I start a connexion with login ppp1, the server gets the line
and the modem answers...getty starts to move... but in the logs nothing
happen, no /usr/sbin/ppp starts.

Does anybody has a clue regarding the reason why getty doesn't spawn  a
ppp ?

For fun I sued 'ppp1'...then few lines appeared in
/var/log/ppp.log....following
 Jul 16 11:39:00 mail ppp[14829]: Phase: Using interface: tun0
 Jul 16 11:39:00 mail ppp[14829]: Phase: deflink: Created in closed
state
 Jul 16 11:39:00 mail ppp[14829]: Warning: set phase: Invalid command
 Jul 16 11:39:00 mail ppp[14829]: Warning: set phase: Failed 1
 Jul 16 11:39:00 mail ppp[14829]: Warning: set phase: Invalid command
 Jul 16 11:39:00 mail ppp[14829]: Warning: set phase: Failed 1
 Jul 16 11:39:00 mail ppp[14829]: Phase: PPP Started (direct mode).
 Jul 16 11:39:00 mail ppp[14829]: Phase: bundle: Establish
 Jul 16 11:39:00 mail ppp[14829]: Phase: deflink: closed -> opening
 Jul 16 11:39:00 mail ppp[14829]: Phase: deflink: Connected!
 Jul 16 11:39:00 mail ppp[14829]: Phase: deflink: opening -> lcp
 Jul 16 11:39:16 mail ppp[14829]: Phase: deflink: Disconnected!
 Jul 16 11:39:16 mail ppp[14829]: Phase: deflink: Connect time: 16 secs:
40  octets in, 355 octets out
 Jul 16 11:39:16 mail ppp[14829]: Phase:  total 24 bytes/sec, peak 32
bytes/sec on Fri Jul 16 11:39:16 1999
 Jul 16 11:39:16 mail ppp[14831]: Phase: 14829 -> 14831: Dropped
session  control
 Jul 16 11:39:16 mail ppp[14831]: Phase: deflink: lcp -> closed
 Jul 16 11:39:16 mail ppp[14831]: Phase: bundle: Dead
Jul 16 11:39:16 mail ppp[14831]: Phase: PPP Terminated (normal).

mail#/etc/ttys
 ttyd0   "/usr/libexec/getty std.38400"  dialup  on secure
 ttyd1   "/usr/libexec/getty std.38400"  dialup  on secure

mail# ps ax | grep getty
 10447  ??  I      0:00.02 /usr/libexec/getty std.38400 ttyd1
 11421  ??  I      0:00.02 /usr/libexec/getty std.38400 ttyd0

mail# more /etc/ppp/ppp.secret
 # Authname Authkey      Peer's IP address        Label   Callback
 ppp1    *

mail# vipw
 ppp1:$r0U6I34/:1000:1000::0:0:accessPPP:/home/ppp1:/usr/local/bin/ppplogin

mail# more /usr/local/bin/ppplogin
 #!/bin/sh
 exec /usr/sbin/ppp -direct spqr-in

mail# more /etc/ppp/ppp.conf
 default:
  allow users *
   enable PAP
   set phase lcp chat debug
   set timeout 0
   enable lqr
   accept lqr
   enable passwdauth

 spqr-in:
         allow users *
         enable pap
         enable proxy
         enable passwdauth
         enable lqr
         accept lqr

 ttyd0:
   set ifaddr 10.10.1.88 10.1.1.88 255.255.255.0

 ttyd1:
   set ifaddr 10.10.1.99 10.1.1.99 255.255.255.0

 
 
 

1. PPP doesn't work under 2.0.26 anymore :-(

I finally got the gcc upgrade and got 2.0.26 to compile!!!!

Now when I boot, I get:

SIOCCSIFADDR: No Such Device
SIOCCSIFBRDADDR: No Such Device
SIOCCSIFNETMASK: No Such Device
SIOCADDRT: Network is unreachable

What does this mean?

Also... My old kernel allowed me to ppp connect to my ISP using the pppd and
chat commands.  Now it tells me:

Sorry - PPP is not available on this system

But I set CONFIG_PPP=y when I built my kernel.  I also set NETWORKING and
TCP/IP to 'y'.

Does anyone have any suggestions on either of these?


Thanks in advance for the help!

Jon

2. can not get the IBM IDE 75GB HD

3. IP Accounting doesn't work for PPP dial-ins :-(( ??

4. Color list for setting up X

5. ppp through rlogin doesn't work :-(

6. ipchains: questions?

7. PPP doesn't die, it just doesn't work anymore

8. FreeBSD & Pentium 2

9. PPP and PPP and PPP and PPP and PPP and HEADACHE

10. ppp-on doesn't work, ppp error: tcgetattr

11. 'ppp-on' Works, 'ifup ppp0' Doesn't

12. PPP doesn't connect if I'm not root (already RTFM'd!)

13. Samba: Can't get browsing to work :-( :-( :-(