SSL, Apache 1.3, FreeBSD 4.7, is this strange or what?

SSL, Apache 1.3, FreeBSD 4.7, is this strange or what?

Post by Mike Tod » Thu, 26 Jun 2003 16:58:26



Everything is from the 4.7 (Released) ports collection.

All of the web sites are Virtual and have been running for years.

SSL was just added:

Jun 24 14:16 apache+mod_ssl-1.3.27+2.8.11
Jun 24 20:23 openssl-0.9.6g

I added "Listen xxx.xxx.xxx.xxx:443 to the Listen...:80 already in the
httpd.conf file.

I restarted Apache using the apachectl startssl command.

But it is not working correctly.

I can connect to any of the sites by using http://www.xxx.xxx:443 but I get
"The page cannot be displayed" when I use https://www.xxx.xxx to connect.

curl https://localhost gives the following error:
curl: (7) Failed connect to localhost: 61

openssl s_client -connect localhost:443

produces
connect: Connection refused

connect:errno=61

Apparently, errno=61 is a socket error of some kind but I'm not sure what to
adjust in order to get past this one.

Anyone have a suggestion?

--

Mike Todd

 
 
 

1. setting up Apache 1.3.27 with the ssl on Freebsd 4.7(stable)

I am trying to setup Apache on FreeBSD 4.7(stable).  I installed the
apache+mod_ssl-1.3.27+2.8.11 package. I configured the httpd.conf
without trouble and it passed the syntax tests. I ran the command:

# apachectl configtest

and "Syntax OK" was returned. When i run

# apachectl start
or
# apachectl startssl

this was returned:

apachectl start: httpd could not be started
or
apachectl startssl: httpd could not be started
respectively.

I am very confused by this nebulous error. I don't know where to go
from here. I am not sure what i could test to determine the a
solution.

I have another question about how i could get it to start on boot up.
I did not see a way to start it in the rc.conf file. Is there another
way have it on startup.

Thank you for your help,
Robert Stickney

2. Recent TeX ports?

3. Newbie: Mozilla 1.3 and FreeBSD 4.7

4. How to schedule a job?

5. SIGBUS on FreeBSD 4.7-S / Native JDK 1.3

6. Printerchange when rebooting

7. Apache w/ SSL in 4.7 how ?

8. Help with Sprynet PPP

9. Apache 1.3.x problems starting SSL

10. Apache 1.3 + SSL 0.8.0

11. apache 1.1.1 + ssl 1.3 -> core dump???

12. Is Apache 1.3.x With SSL Usable On Ultrix ?

13. Transient "localhost" IP problems on Apache 1.3+SSL