cdrtools/cdrecord broken on SCSI devices!

cdrtools/cdrecord broken on SCSI devices!

Post by O. Hartman » Mon, 24 Dec 2001 03:00:36



Hello.

This is the second time I fall into serious trouble with cdrtools/cdrecord.

We have two machines used by administration to burn either ISO images like
those prepared by freebsd.org or selfmade by mkisofs. Both machines are
architectural different but both use SCSI and SCSI CDR for this purpose.

On both machines FreeBSD 4.5-PRERELEASE is installed (but the problem
is also in FreeBSD 4.4-RELEASE AND 4.4-STABLE present).
One machine, a AMD K7 machine, uses a TEAC CD-R55S 1.0R recorder
with cdrtools 1.10_1 as recently cvsupdated and installed.

The other machine is a AMD K6-2/550 with a PLEXTOR CD-R   PX-R412C 1.07.

Both machines do not have any problems with the SCSI device nor with reading
CD ROMs on both drives! But they have problems generating readable CD ROMS
with their burners!

I tried nearly all possible combinations, simple, complex, 1,2,3 or 4 speed,
selfmade ISO images, prepared ISO images (installation CDs from freebsd.org),
but it is on both systems the same: the burning process shows no errors,
alls things seems to be all right, but the CD ROMs are unreadable on both UNIX
or PC systems. This problem occured the first time when I changed from the
old cdrecord-port to cdrtools-port.

Please, if someone out here uses also older CD recorders like the TEAC or
PLEXTOR models on SCSI subsystems and also uses cdrecord (it is the only tools
available for FBSD to burn CDs on UNIX), do you see this problem also?
Let me know if there is a known problem/solution to this problem, it is
very serious to me.

Thanks in advance,

Oliver

--
--
MfG
O. Hartmann


------------------------------------------------------------------
IT-Administration des Institutes fuer Physik der Atmosphaere (IPA)
------------------------------------------------------------------
Johannes Gutenberg Universitaet Mainz
Becherweg 21
55099 Mainz

Tel: +496131/3924662 (Maschinenraum)
Tel: +496131/3924144 (Buero)
FAX: +496131/3923532

 
 
 

cdrtools/cdrecord broken on SCSI devices!

Post by Stefan Walte » Mon, 24 Dec 2001 20:52:04


O. Hartmann maltr?tierte seine Tastatur mit:

Quote:> On both machines FreeBSD 4.5-PRERELEASE is installed (but the problem
> is also in FreeBSD 4.4-RELEASE AND 4.4-STABLE present).
> One machine, a AMD K7 machine, uses a TEAC CD-R55S 1.0R recorder
> with cdrtools 1.10_1 as recently cvsupdated and installed.

> The other machine is a AMD K6-2/550 with a PLEXTOR CD-R   PX-R412C 1.07.

> Both machines do not have any problems with the SCSI device nor with reading
> CD ROMs on both drives! But they have problems generating readable CD ROMS
> with their burners!

Burning works fine with me on the following system (with both
single-session, multi-session and DAO [/usr/ports/audio/cdrdao]):


[...]
CPU: AMD Duron(tm) processor (900.04-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x631  Stepping = 1
[...]
cd1 at ahc0 bus 0 target 4 lun 0
cd1: <TEAC CD-R55S 1.0L> Removable CD-ROM SCSI-2 device
cd1: 10.000MB/s transfers (10.000MHz, offset 15)
cd1: Attempt to query device size failed: NOT READY, Medium not present
[...]

FreeBSD dunkelkammer.void 4.5-PRERELEASE FreeBSD 4.5-PRERELEASE #0: Sun
Dec 23 00:10:33 CET 2001

My /usr/src is from yesterday evening, at around 8pm CET.

Do you burn the CDs with cdrecord's DAO option, or without it? I'm not
sure, but I think someone told me he had a few problems with it. I have
never seen any problems, though, as I never use that option.

Stefan
--
No reading beyond this point
PGP key: http://homepages.compuserve.de/SWDunkelkammer/dunkelkammer.asc
PGP key fingerprint: 6719 7C67 E188 4419 C7F6  786E 58C0 AEBF 5796 6947

 
 
 

1. cdrecord and SCSI devices

Hello:

I am troulble-shooting CD burning on my Linux workstation.  The cdrecord
-scanbus option results in the following error message:

cdrecord: Warning: controller returns wrong size for CD capabilities page.
cdrecord: Warning: controller returns wrong page 20 for CD capabilities page (2A).

My CD devices are a Teac SCSI cd-rom and a Yamaha SCSI cdr. Both devices
are recognized by the system and seem to be working fine.  Can anybody
tell me how to begin to trblsht these error messages from 'cdrecord
-scanbus'.  I have read the cdrecord man pages and the help to my front
end, gtoaster, to no avail.  

TIA, very frustrated
campbell

2. Modem / Linux / USR / Dial-in problem

3. cdrecord hangs system when accessing SCSI device

4. Slow telnet and ftp response

5. linuxppc 2.2.17 / cdrecord 1.10a04 - scsi device MADNESS!

6. MIDI for linux

7. cdrecord 1.8a21 fails with scsi error "write_g1: scsi sendcmd: retryable error"

8. PASV FTP

9. Cdrtools-1.10a04 supports Remote SCSI

10. Problems with 2.5.*'s SCSI headers and cdrtools

11. Problems using cdrecord to scsi cdwriter from scsi hard drive

12. 2.4 loop device over block device broken

13. cdrecord-cdda2wav broken?