Help need: Sound config and epplet config

Help need: Sound config and epplet config

Post by Home » Mon, 20 Mar 2000 04:00:00



Hi,

Sorry, I have to post this again.

I have problem with use the sound card in Freebsd. I have configured my
SB AWE64 correctly.(shown in /dev/sndstat) However, when I try to use
x11amp or xmms,

the first one give an error said:

Unable to get fragment size
Unable to open the audio device ( I have /dev/audio and /dev/audio0 )

The second one halt and I have to kill it . (problem: need a thread-saft

xlibs don't know where to get it and which ports need to compile)

The cdrom audio works. ( I tested it)

Can anyone show me which how to solve the problem?

Another question is the epplet from enlightenment. Some of them does not

work in freebsd.
For those epplet, which monitoring the network like E-NetFrame or
E-NetGraph. They keep asking for
/dev/eth0 which, I regonized, is a linux device.

Can anyone show me how to make the epplet detect the right device in
Freebsd?

Also, I can't find  My network device in the directory /dev. My network
device is xl0.

Do anybody know which /dev/* is  used by the network card?

Thanks

newbie

 
 
 

Help need: Sound config and epplet config

Post by Andre van Straate » Mon, 20 Mar 2000 04:00:00


For some reasons, which I still don't understand, x11amp plays only wav
files, and mp3 files I can hear only with mpg123. I use it together with
xhippo.


> Hi,

> Sorry, I have to post this again.

> I have problem with use the sound card in Freebsd. I have configured my
> SB AWE64 correctly.(shown in /dev/sndstat) However, when I try to use
> x11amp or xmms,

> the first one give an error said:

> Unable to get fragment size
> Unable to open the audio device ( I have /dev/audio and /dev/audio0 )

Check with ps the background jobs. When you test various programs, or
one multiple times, make sure the previous job has finished.

Regards,
Andre

Quote:

> The second one halt and I have to kill it . (problem: need a thread-saft

> xlibs don't know where to get it and which ports need to compile)

> The cdrom audio works. ( I tested it)

> Can anyone show me which how to solve the problem?

> Another question is the epplet from enlightenment. Some of them does not

> work in freebsd.
> For those epplet, which monitoring the network like E-NetFrame or
> E-NetGraph. They keep asking for
> /dev/eth0 which, I regonized, is a linux device.

> Can anyone show me how to make the epplet detect the right device in
> Freebsd?

> Also, I can't find  My network device in the directory /dev. My network
> device is xl0.

> Do anybody know which /dev/* is  used by the network card?

> Thanks

> newbie


 
 
 

1. Need help with sound config

Hi All:

I am trying to run/listen a mp3 from my cd and I fail to do that. I
run sndconfig and selected SB Pro and I can hear the sample sound and
MIDI and everything sounds good. BUT when I put my cd in, run gtcd or
any other multimedia program, It fails to run mp3s in that CD. Has
this to do something with my mounted CD and/or SOund configuration?
How can I find that out? I do remember I had to change couple of
things in ftab and mtab files to make my cd mount on /mnt/cdrom.
Initially it was mounting on /cdrom, which I didn't like. Right now I
can cd to /mnt/cdrom and ls all the files. But then why does it fail
to play my mp3s?
Any other comments will be highly appreciated.

My Machine specs are
Toshiba Tecra 8000
Redhat 7.1

regards

2. High Speed CPU's

3. Sound config in X win- need help

4. Xfree86 (3.3.5) don1t works on a Asus Banshee V3200!!

5. Need Help: sound and epplet in FreeBSD

6. Printer logs!!!

7. patch 01/38: switches in fs/Config.in, fs/Config.help

8. RAM Compression for Linux

9. REPOST patch 38/38: switches in fs/Config.in, fs/Config.help

10. 2.5.5-dj2, add 9 help texts to sound/oss/Config.help

11. 2.5.7-dj1, add 1 help text to sound/oss/Config.help

12. need config for yamaha OPL3-SA sound card

13. need drivers/sound/Config.in