Cvsup 4.2 >> to >> 4.5

Cvsup 4.2 >> to >> 4.5

Post by Aaro » Wed, 10 Apr 2002 10:00:30



Hi

I'm cvsuping three servers to freebsd 4.5 from 4.2.
My first two boxes completed with no problems.

My last box is having major problems.

Let me explain a little into detail

I first Cvsuped source down to my box.

Then when doing a make build world in source directory it crashes.
It gets maybe a minute into the make build world, and gives me an error of
panic, then crashes.

I then tried deleting /usr/obj to start over, But when trying to delete the
folder in the order that is shown at freebsd's site it say's panic, then
crashes again.

I can't delete the folder at all what so ever, but am able to mv it to a
different location.

While trying, I have moved two /usr/obj's over to a different directory.
I also Have deleted my source, too try again - incase my source was messed
up.

Two questions

Any Idea why it crashed with make buildworld.
and how can I get rid of the other two directories that I have moved from
/usr/obj.

Any help would be really really great.

Best Regards

Aaron

 
 
 

Cvsup 4.2 >> to >> 4.5

Post by Paul Southwor » Wed, 10 Apr 2002 08:08:35




>I'm cvsuping three servers to freebsd 4.5 from 4.2.

I recommend going to RELENG_4_5 instead of the -RELEASE version.
That way you will also get critical/security fixes.

Quote:>My first two boxes completed with no problems.

>My last box is having major problems.
[...]
>Then when doing a make build world in source directory it crashes.
>It gets maybe a minute into the make build world, and gives me an error of
>panic, then crashes.

This is probably a hardware problem.  The two most common causes
in my experience are inadequate CPU or system cooling, and bad RAM.

--Paul

 
 
 

Cvsup 4.2 >> to >> 4.5

Post by Aaro » Wed, 10 Apr 2002 10:23:00


Hi

Yea, I download from the stable source branch.

I will try replacing the ram and see if that does the job.
The cooling is pretty good, its in a rackmount case with mega fans blowing.

Thanks for your reply :)

Best Regards

Aaron




> >I'm cvsuping three servers to freebsd 4.5 from 4.2.

> I recommend going to RELENG_4_5 instead of the -RELEASE version.
> That way you will also get critical/security fixes.

> >My first two boxes completed with no problems.

> >My last box is having major problems.
> [...]
> >Then when doing a make build world in source directory it crashes.
> >It gets maybe a minute into the make build world, and gives me an error
of
> >panic, then crashes.

> This is probably a hardware problem.  The two most common causes
> in my experience are inadequate CPU or system cooling, and bad RAM.

> --Paul

 
 
 

Cvsup 4.2 >> to >> 4.5

Post by Drew Laws » Wed, 10 Apr 2002 08:22:06




Quote:>Then when doing a make build world in source directory it crashes.
>It gets maybe a minute into the make build world, and gives me an error of
>panic, then crashes.

When you say "panic" do you really mean it?
You get a kernel panic, and the machine crashes/reboots?

If so, that is probably a memory problem (or other hardware problem).

Quote:>I then tried deleting /usr/obj to start over, But when trying to delete the
>folder in the order that is shown at freebsd's site it say's panic, then
>crashes again.

>I can't delete the folder at all what so ever, but am able to mv it to a
>different location.

You, as root, cannot remove it?
What error message do you get?

Quote:>Any Idea why it crashed with make buildworld.

Error messages would be helpful.
If only the compile (and not the machine) is crashing, you probably
have a dependency problem.  Have you read the parts of /usr/src/UPDATING
from 4.2's release to the present?

--
|Drew Lawson            | If you're not part of the solution |

|http://www.furrfu.com/ |                                    |

 
 
 

Cvsup 4.2 >> to >> 4.5

Post by Aaro » Wed, 10 Apr 2002 10:34:48





> >Then when doing a make build world in source directory it crashes.
> >It gets maybe a minute into the make build world, and gives me an error
of
> >panic, then crashes.

> When you say "panic" do you really mean it?
> You get a kernel panic, and the machine crashes/reboots?

Well it was yesterday that I atually did it, so I don't have the actual
error messages
But what I recall was that it said panic of some sort.

Quote:

> If so, that is probably a memory problem (or other hardware problem).

> >I then tried deleting /usr/obj to start over, But when trying to delete
the
> >folder in the order that is shown at freebsd's site it say's panic, then
> >crashes again.

> >I can't delete the folder at all what so ever, but am able to mv it to a
> >different location.

> You, as root, cannot remove it?
> What error message do you get?

Yea, as root I cannot Delete it, When Trying it gave the same error as when
doing the make build world.
All I can do is move it around.

Quote:

> >Any Idea why it crashed with make buildworld.

> Error messages would be helpful.
> If only the compile (and not the machine) is crashing, you probably
> have a dependency problem.  Have you read the parts of /usr/src/UPDATING
> from 4.2's release to the present?

Yea It's both the compile and system. I did two other boxes which had same
version 4.2 with no problems.

One weird thing is tho, If I don't try to touch that file and don't make
build world, every thing else works just fine DNS- email- Apache ..etc.
I'm hosting about 100 people on that box. I will try replaing the ram
tommorow and try again

Thanks for all the replys

Best regards

Aaron

> --
> |Drew Lawson            | If you're not part of the solution |

> |http://www.furrfu.com/ |                                    |

 
 
 

Cvsup 4.2 >> to >> 4.5

Post by Henrik Larsso » Thu, 11 Apr 2002 16:11:37


Quote:> how can I get rid of the other two directories that I have moved from

/usr/obj.

Try: chflags -R noschg * /usr/obj

Then remove what you wan't from /usr/obj

The files have proberbly the immutable bit set so even the root can
accidently delete the them.

Best regards Henrik

 
 
 

1. <><><> MOUNTING EXTENDED PARTITION <><><>

I have a 10 GB UDMA IDE drive formatted with Windows.  The first partition
is FAT32, and the second is NTFS.  I can successfully mount the first, but
not the second.  Any ideas?

Suse 7.2 on i86
the drive is mounted on /dev/hdc, and I CAN see hda1, but not hda2

2. Q:man page to text file?

3. Wanted: <><><> Unix Specialist <><><>

4. Logout/Kill processes not being used?

5. LILO help <><><><><><>

6. can't get ethernet card to work

7. >>---> Software Jobs! >>--->

8. determine the current directory of a son-process

9. 4.2->5.0->5.0.2->Comet ??

10. Win95/IPX -> IP ->PPP ->Linux ->Novell 3.12

11. <Alt>+<key> = <Esc><key> ?

12. A <= ping => B => OK A <= TCP => B => FAILS

13. FTP problem: linux>>win/SGI slow win/SGI>>linux fast