FBSD install and mount problem

FBSD install and mount problem

Post by Peter Kostouro » Mon, 08 May 2000 04:00:00



Hi

I am trying to install FBSD 4 from CD discs, but the installer refuses
to create a root mount point. To clarify, I have a drive with 4 primary
partitions, 32M, 32M, 4GB, 5GB. The 2 32MB partitions were created so
I could load several OSs (so their boot programs/information lie within
the 1024 cylinder limit). The 4GB partition already has FBSD3.4 on it
(and I do not with to upgrade this installation). The 5GB is free to
which I wish to create several slices and mount /usr, /var, ... under.
I can slice the 5GB partition and create mount points for it other that
root - the installer mentions that the region cannot be used for the
root partition. When I try to put root in the first partition, I get
something along the lines that the region cannot be used for the root
partition as the FBSD boot code cannot deal with a root partition
created in that location, select another location or smaller size.
I have tried creating 30MB and 20 MB slices within this partition, but
the installer still complains.

The disk drive is the primary drive on the secondary IDE thingamajig.

Can anyone offer any insights?

--

Regards

Peter


 
 
 

FBSD install and mount problem

Post by Cyrille Lefevr » Mon, 08 May 2000 04:00:00



> Hi

> I am trying to install FBSD 4 from CD discs, but the installer refuses
> to create a root mount point. To clarify, I have a drive with 4
> primary partitions, 32M, 32M, 4GB, 5GB. The 2 32MB partitions were
> created so I could load several OSs (so their boot
> programs/information lie within the 1024 cylinder limit). The 4GB
> partition already has FBSD3.4 on it (and I do not with to upgrade this
> installation). The 5GB is free to which I wish to create several
> slices and mount /usr, /var, ... under.  I can slice the 5GB partition
> and create mount points for it other that root - the installer
> mentions that the region cannot be used for the root partition. When I
> try to put root in the first partition, I get something along the
> lines that the region cannot be used for the root partition as the
> FBSD boot code cannot deal with a root partition created in that
> location, select another location or smaller size.  I have tried
> creating 30MB and 20 MB slices within this partition, but the
> installer still complains.

> The disk drive is the primary drive on the secondary IDE thingamajig.

> Can anyone offer any insights?

I see in the code of the sysinstall program that all the partition
containing the root slice should be w/in the first 1024 cylinders,
not only the beginning of the partition.

I guess that your 4GB doesn't fit /win the 1024 first cylinders.
try to shrink it to 2 GB, even 1GB if necessary.

Cyrille.
--



 
 
 

FBSD install and mount problem

Post by Peter Kostouro » Mon, 08 May 2000 04:00:00


Hi

I deleted and recreated the first partition (32M) and all is well.
Originally the disk was partitioned using Linux's fdisk about a year ago
so I guess that was could have been the problem.

--

Regards

Peter


 
 
 

1. FBSD 2.2.2 Mount Problem

Oops..  I added a third IDE drive into my FBSD 2.2.2 box, configured it,
mounted it, etc...  Everything was running fine and then the system was
shutdown and restarted (about 8 months later!).

Problem is that I cannot remember the mount syntax I used and I can't seem
to work it out properly myself.  The drive is configured as wd3, and fdisk
gives me the following info:

-------------------------------
su-2.01# fdisk wd3
******* Working on device /dev/rwd3 *******
parameters extracted from in-core disklabel are:
cylinders=1654 heads=16 sectors/track=63 (1008 blks/cyl)

 Figures below won't work with BIOS for partitions not in cyl 1
parameters to be used for BIOS calculations are:
cylinders=1654 heads=16 sectors/track=63 (1008 blks/cyl)

Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 0 is:
<UNUSED>
The data for partition 1 is:
<UNUSED>
The data for partition 2 is:
<UNUSED>
The data for partition 3 is:
sysid 165,(FreeBSD/NetBSD/386BSD)
    start 0, size 50000 (24 Meg), flag 80
        beg: cyl 0/ sector 1/ head 0;
        end: cyl 1023/ sector 63/ head 255

-------------------------------

Running disklabel on the device gives me the following:

-------------------------------
su-2.01# disklabel -r wd3
# /dev/rwd3c:
type: unknown
disk:
label:
flags:
bytes/sector: 512
sectors/track: 63
tracks/cylinder: 16
sectors/cylinder: 1008
cylinders: 1654
sectors/unit: 1667232
rpm: 3600
interleave: 1
trackskew: 0
cylinderskew: 0
headswitch: 0           # milliseconds
track-to-track seek: 0  # milliseconds
drivedata: 0

3 partitions:
#        size   offset    fstype   [fsize bsize bps/cpg]
  c:  1667232        0    unused        0     0         # (Cyl.    0 - 1653)
-------------------------------

It would seem to me that 'mount /dev/wd3c /newmnt' should work but it
doesn't.  I know I should be able to dig this up myself but can't seem to do
so.  Can anyone help me with this?  Please forward replies to email as I
don't manage to pick up this mewsgroup reliably.

Thanks,
Don Dunlop

2. MT-LEVEL entry in man pages?

3. Matrox Mystique ands X.

4. problem with pppsetup

5. FBSD 2.2.2R install problem

6. newbie kppp problem

7. Problem installing StarOffice5 on FBSD-3.4

8. Man page to a permanent ASCII file....??

9. Help! FBSD 3.2 install problem

10. FBSD 4.0 install problem?

11. FBSD 2.2.7-RELEASE install problem- SCSI controller

12. FBSD 3.1-RELEASE install problem

13. install problem with FBSD 3.4