FreeBSD + Linux EMU + Linux Glide and DGA instability

FreeBSD + Linux EMU + Linux Glide and DGA instability

Post by Dominik Beh » Sat, 26 Sep 1998 04:00:00



i have installed linux glide rpms on my 2.2.7
hoping that my voodoo will work in freebsd
but kernel bombs me with iopl() not supported messages
when i run test glide application

i suppose linux emulation does not support direct access
to io ports that glide needs

so i have two questions
1. will there be better linux emulation ?
2. will there be glide for freebsd ?

btw, i have experienced nice system crashes and reboots
running programs that use DGA in XFree86. crash happens
when program exits and closes DGA. (mine programs and some DGA
examples i have found on the net). it happens with various
xservers and xfree versions.

i'd appreciate direct email respones
dominik behr

 
 
 

FreeBSD + Linux EMU + Linux Glide and DGA instability

Post by Jordan K. Hubba » Sat, 26 Sep 1998 04:00:00



> i have installed linux glide rpms on my 2.2.7
> hoping that my voodoo will work in freebsd
> but kernel bombs me with iopl() not supported messages
> when i run test glide application

iopl() and a bunch of other linux functions are now supported by the
2.2.7-stable linux emulator as well as the 3.0-current one.  If you
grab -stable's latest /usr/src/i386/linux directory and compile up a
new linux lkm, it should work.

Quote:> so i have two questions
> 1. will there be better linux emulation ?

Yes, already in place.

Quote:> 2. will there be glide for freebsd ?

Several people are working on it, but I don't have an ETA as of
yet.

--
- Jordan Hubbard
  Co-founder/Release Manager, The FreeBSD Project
  Walnut Creek CDROM

 
 
 

1. 3dfx glide support via linux glide port(s)

ok, i needed (well, wanted) glide support for my 3dfx banshee (creative
labs), so i installed the linux_glide port and it's dependencies.
However, when i execute test-glide, it does not work (installation went
fine, no errors.)  any help would be appreciated

# ./test-glide
test00:
Clear screen to blue
2.4b1
Resolution: 640x480
Press A Key To Begin Test.  *a-key*
_GlideInitEnviroment: glide2x.dll expected Voodoo Graphics, none
detected

this was done and duplicated multiple times under freebsd 3.2 (upgrade
to 3-stable via port) and X windows 3.3.5, KDE WM

~jtsage

Sent via Deja.com http://www.deja.com/
Before you buy.

2. Suggestions on a replacement cd-rom

3. Linux Glide on FreeBSD

4. joliet+nls problem

5. Linux emu: "Elf binary type not known" (StarOffice, FreeBSD 2.2.2)

6. Lost cryptoapi loop data on Linux (with the international kernel patch)

7. Starting FreeBSD 4.0 with Linux or starting Linux with FreeBSD

8. Roaring Penguin PPPoE thru a Network Hub?

9. AMD dual system instability under linux 2.4.7, 2.4.17

10. General Linux Instability

11. Linux INstability & Netscape : Insights?

12. Numerical Instabilities with Linux ???

13. Linux 2.4.3 instabilities, kernel panic with IrDA, ps, etc.