locale problem

locale problem

Post by Benny L » Fri, 07 Jul 2000 04:00:00



hi,

    I did not intend to install any non-english software on FreeBSD, but
many program start up complaining that the C library cannot support the
locale i specified. And some of them may print out my locale setting,
which seems to me is not set:
        LC_LANG = (not set)
        LC_LOCALE = (not set)          or something like that.....

    Can somebody tell me how i can set my locale?

thanks
b

 
 
 

1. java/locale problem on solaris 9

hello,

I have some problems with running java programms (solaris 9/x86 0403). The
problem is that I can't type characters because a testing programm says
that these are unknown keycodes.
It is impossible for me to type evertyhing on the numpad or use any key
which is produced by alt-x (i am using an german sun type6 usb keyboard).
The following line is part of the output of the testing utility I am
using.

java.awt.event.KeyEvent[KEY_RELEASED,keyCode=0,keyText=Unknown keyCode:
0x0,keyChar='?',keyLocation=KEY_LOCATION_UNKNOWN]

I looked on the web for possible solutions and most them are about the
locale settings, but I am using only the following two locales (which are
correct in my opinion)

LANG=C; LC_CTYPE="C"; LC_NUMERIC="C"; LC_TIME="C"; LC_COLLATE="C";
LC_MONETARY="C"; LC_MESSAGES="C"; LC_ALL=

LANG=en_US.ISO8859-15; LC_CTYPE=en_US.ISO8859-15; LC_NUMERIC=en_US.ISO8859-15
LC_TIME=en_US.ISO8859-15; LC_COLLATE=en_US.ISO8859-15;
LC_MONETARY=en_US.ISO8859-15; LC_MESSAGES=C; LC_ALL=

both of the above setting don't solve the problem. I also tried different
versions of java to be sure.

java version "Solaris_JDK_1.2.2_12" (supplied with solaris x86/0403)
java version "1.4.2" (downloaded from java.sun.com)

Anyone can point me into the right direction ?

Walter

--
SILVER SERVER \\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\ \\\\\\ \\            

web: www.sil.at          \               -- Kevin Harris

2. Vulnerability in UW Pine <= 4.56

3. locale problem with gdk; /dev/dsp ??

4. Two IP (PPP and le0) on one host. HOW?

5. libc 5.0.9 and locale problem.

6. Duplexed SCSI Drive setup

7. Locales problem with Sybase moving from AIX 4.1.5 to 4.3.3

8. Tun - no such device ???

9. locale problem

10. settings of locale (Problem with system and utf8)

11. locale problem at gnome -- how to solve?

12. rpm -bb locale problems

13. linux-jdk14 locale problems