Trouble setting up dual NIC machine

Trouble setting up dual NIC machine

Post by Nils M Hol » Thu, 27 Dec 2001 22:51:56



I am currently trying to set up a DSL router using an old 486SX25 box
running FreeBSD 4.4. The machine has 8M bytes of RAM, an IDE disk, a
VGA video board, and two 3C509 NICs:

ep0 IP=10.0.0.198
ep1 IP=10.0.0.199

On a machine connected to ep0 I can log in to 10.0.0.198 without any
trouble.

When I try telnet 10.0.0.199 from a machine connected to ep1, however,
I get a timeout error and the kernel on the DSL router prints:

Dec 23 21:29:30 firewall /kernel: 10.0.0.11 is on ep0 but got reply from \
(MAC of 10.0.0.11 follows) on ep1

This does not make any sense to me, since 10.0.0.11 is not even
physically connected to ep1.

Also, when the machine is booting I get a bit confused by this message:

Dec 23 21:07:58 firewall routed[120]: ep1 (10.0.0.199/24) is duplicated
 by ep0 (10.0.0.198/24)

The NICs are detected as follows:

Dec 23 21:03:07 firewall /kernel: ep0: <3Com 3C509-TPC EtherLink III>
 at port 0x300-0x30f irq 10 on isa0
Dec 23 21:03:07 firewall /kernel: ep0: Ethernet address 00:60:97:15:72:2f

Dec 23 21:03:07 firewall /kernel: ep1: <3Com 3C509-TPC EtherLink III>
 at port 0x320-0x32f irq 11 on isa0
Dec 23 21:03:07 firewall /kernel: ep1: Ethernet address 00:60:97:15:74:9f

Any ideas what is going wrong?

Thank you for your time.

Nils.

--

 
 
 

Trouble setting up dual NIC machine

Post by Henri Henneber » Fri, 28 Dec 2001 02:43:54


Nils,

You may not give 2 IP adresses in the same subnet (10.0.0.0/24 in your
case) to 2 differents NICs; the routed deamon can't route packets because
the 2 NICs are on the same net.

Try something like:

ep0 IP 10.0.1.198 with netmask 24
ep1 IP 10.0.2.198 with netmask 24

Hope it help
Henri


> I am currently trying to set up a DSL router using an old 486SX25 box
> running FreeBSD 4.4. The machine has 8M bytes of RAM, an IDE disk, a
> VGA video board, and two 3C509 NICs:

> ep0 IP=10.0.0.198
> ep1 IP=10.0.0.199

> On a machine connected to ep0 I can log in to 10.0.0.198 without any
> trouble.

> When I try telnet 10.0.0.199 from a machine connected to ep1, however,
> I get a timeout error and the kernel on the DSL router prints:

> Dec 23 21:29:30 firewall /kernel: 10.0.0.11 is on ep0 but got reply from \
> (MAC of 10.0.0.11 follows) on ep1

> This does not make any sense to me, since 10.0.0.11 is not even
> physically connected to ep1.

> Also, when the machine is booting I get a bit confused by this message:

> Dec 23 21:07:58 firewall routed[120]: ep1 (10.0.0.199/24) is duplicated
>  by ep0 (10.0.0.198/24)

> The NICs are detected as follows:

> Dec 23 21:03:07 firewall /kernel: ep0: <3Com 3C509-TPC EtherLink III>
>  at port 0x300-0x30f irq 10 on isa0
> Dec 23 21:03:07 firewall /kernel: ep0: Ethernet address 00:60:97:15:72:2f

> Dec 23 21:03:07 firewall /kernel: ep1: <3Com 3C509-TPC EtherLink III>
>  at port 0x320-0x32f irq 11 on isa0
> Dec 23 21:03:07 firewall /kernel: ep1: Ethernet address 00:60:97:15:74:9f

> Any ideas what is going wrong?

> Thank you for your time.

> Nils.


 
 
 

Trouble setting up dual NIC machine

Post by Nils M Hol » Sat, 29 Dec 2001 02:15:29



> You may not give 2 IP adresses in the same subnet (10.0.0.0/24 in your
> case) to 2 differents NICs; [...]

That was exactly the problem. Time to read the manual, I guess.

Thanks,

Nils.

--

 
 
 

1. dual nic in Solaris 8 machine

Hi,

i have two ethernet-cards in my E250 running Solaris 8...  I noticed
these have the same mac-address...  

The intention is that these cards are both connected to different
network-segments...  However these segements are also connected to
each-other using routers...  The goal is to let one department work
using hme0 and the other using hme1...  So department1 does not have
to go via the router and does therefore not get the traffic from
department 2...

I presume i need to change the mac-address from one nic...  Why did
Sun do this anyway...?

2. fputs bug

3. RH5.2 Dual NIC Startup Troubles

4. Installing from Downloaded install image - Help!

5. Dual NIC Troubles

6. Remote Backup

7. Two 3com509B NIC's in one machine, trouble.

8. Weird XSetDashes() crash

9. Shape Ups,Men's Shape Ups,Men's Skechers Shape Ups - new styles!

10. 10BASE-T NIC and 100mbps NIC to a dual-speed hub doesn't work?

11. Binding services to a NIC in a dual NIC system possible?

12. Dual NIC or Single NIC for cable modem connection?

13. How to set up a linux machine with multiple NICs as a hub/swich?