STABLE isn't: kernel won't compile

STABLE isn't: kernel won't compile

Post by Soren Ragsdal » Fri, 19 Jun 1998 04:00:00



New install of 2.2.6.  Cvsup'ed to FreeBSD-STABLE using the definitions in
/usr/share/examples/cvsup/stable-supfile.  I went back to compile the
GENERIC kernel (just to prove to myself that it would work, before
compiling my own) and the generic kernel compile fails with the following
message:

loading kernel
isa.o: Undefined symbol '_isa_devtab_cam' referenced from text segment
(repeats 8 times)

Any idea?

 
 
 

STABLE isn't: kernel won't compile

Post by Dinesh Nai » Sat, 20 Jun 1998 04:00:00



> compiling my own) and the generic kernel compile fails with the following
> message:

> loading kernel
> isa.o: Undefined symbol '_isa_devtab_cam' referenced from text segment
> (repeats 8 times)

build the new /usr/sbin/config in /usr/src/usr.sbin/config before
con* the new kernel.

--
Regards,                        /\_/\   "All dogs go to heaven."

+=======================----oOO--(_)--OOo----=========================+
|for a in past present future; do                                     |
| for b in clients employers associates relatives neighbours pets; do |
| echo "The opinions here in no way reflect the opinions of my $a $b."|
|done; done                                                           |
+=====================================================================+
http://www.veryComputer.com/

 
 
 

STABLE isn't: kernel won't compile

Post by Brian Some » Sat, 20 Jun 1998 04:00:00




: New install of 2.2.6.  Cvsup'ed to FreeBSD-STABLE using the definitions in
: /usr/share/examples/cvsup/stable-supfile.  I went back to compile the
: GENERIC kernel (just to prove to myself that it would work, before
: compiling my own) and the generic kernel compile fails with the following
: message:
:
: loading kernel
: isa.o: Undefined symbol '_isa_devtab_cam' referenced from text segment
: (repeats 8 times)

Always ``make world'', then config & build your kernel.  If you don't
do things in this order, you suffer from errors like this (due to the
wrong config(8) as Dinesh Nair has already pointed out).

I use something like:

  cd /usr/src &&
  make buildworld &&
  make installworld &&
  cd /sys/i386/conf &&
  config mykernel &&
  cd /sys/compile/mykernel &&
  make depend &&
  make all install

: Any idea?

--

      <http://www.Awfulhak.org>
Don't _EVER_ lose your sense of humour !

 
 
 

1. help needed: AWE32 PNP won't work - kernel won't compile - gurus read this!

Hello all,

I went through the Sound howto files, I tried to make the AWE32 PNP
work via the /etc/rc.d/rc.modules (auto detect for IRQ 5 DMA1 and 5)
I tried to compile my kernel for the AWE32 PNP sound blaster but the
message I receive while compiling is:
sb_common.c:21: #error You will need to configure the sound driver
with
CONFIG_AUDIO option.
sb_common.c:266: warning: `sb16_set_mpu_port' defined but not used
make[2]: *** [sb_common.o] Error 1
make[1]: *** [sub_dirs] Error 2
make: *** [linuxsubdirs] Error 2

Any suggestions/solutions. There seems to be no way of dactivating
the mpu interface with the make config option. Nor I do not now how to
enable it or disable it on the soundcard.

Thanks for your  replies!!!!!!!!

2. Problem running aterm with KDE

3. perl won't compile on OpenBSD-2.9 and OpenBSD-2.9-stable.

4. change mode to -rws------

5. KDE 1.1.2 won't compile under FreeBSD 3.3-STABLE

6. how to conect to comps with ethernet cards?

7. kernel won't compile/can't make LU005 work!

8. KDSETKEYCODE work with new input layer?

9. 2.2.5-stable won't compile!!

10. HELP: Yggdrasil fall '94 won't compile kernel.

11. licq-0.75.3a port won't compile on 3.4-Stable

12. HELP: Yggdrasil fall '94 won't compile kernel.

13. Linux won't boot if my ethernet card isn't connected