pcm0 error, SDL error, or soundcard error?

pcm0 error, SDL error, or soundcard error?

Post by zhenti » Wed, 14 Nov 2001 17:21:08



Okay. Well, I have an SB Live! Value card, with:

device  pcm    
device  sbc

In my custom kernel. Here's the basic sndstat:

# cat /dev/sndstat
FreeBSD Audio Driver (newpcm) Nov  9 2001 04:10:01
Installed devices:
pcm0: <Creative EMU10K1> at io 0xd800 irq 12 (4p/3r/0v channels duplex)

I have the SDL 1.2.2 port and have successfully (I hope)

Basically, Exult uses an internal fork of Timidity (in
conjunction with SDL) to play music for the game.

This is where my problems are.. the entire program
stutters. The video effects are very lagged and the audio
output is broken up with large silence gaps in between.
Eventually, on the console, I get this error:

SDL: Audio timeout - buggy audio driver? (disabled)
audio: Bad file descriptor

It seems to me that this could imply that the /dev/dsp
driver is broken, SDL is broken, or my soundcard is just
cheese (I know it is, anyway, but would it be the source
of these problems?).

What do you guys think? Any diagnostics I should attempt
to narrow down the troubleshooting?  

Thanks, guys.
--

FreeBSD 4.4-RELEASE + wmaker 0.65.1

 
 
 

pcm0 error, SDL error, or soundcard error?

Post by zhenti » Wed, 14 Nov 2001 17:35:43


Quote:> SDL: Audio timeout - buggy audio driver? (disabled)
> audio: Bad file descriptor

Oh, just noticed, on tty0:

pcm0: record interrupt timeout, channel dead

Probably related.

--

FreeBSD 4.4-RELEASE + wmaker 0.65.1

 
 
 

pcm0 error, SDL error, or soundcard error?

Post by Jed Clea » Thu, 15 Nov 2001 07:35:22


Anything else show up with the same IRQ in dmesg?

> > SDL: Audio timeout - buggy audio driver? (disabled)
> > audio: Bad file descriptor

> Oh, just noticed, on tty0:

> pcm0: record interrupt timeout, channel dead

> Probably related.

> --

> FreeBSD 4.4-RELEASE + wmaker 0.65.1

 
 
 

pcm0 error, SDL error, or soundcard error?

Post by zhenti » Thu, 15 Nov 2001 11:36:39


Quote:> Anything else show up with the same IRQ in dmesg?

Nope, just the soundcard. The error listed below has only happened a
few times, can't seem to recreate it. But the program's staggering
performance (Exult) is quite constant.


>> > SDL: Audio timeout - buggy audio driver? (disabled)
>> > audio: Bad file descriptor
>> Oh, just noticed, on tty0:
>> pcm0: record interrupt timeout, channel dead
>> Probably related.

--

FreeBSD 4.4-RELEASE + wmaker 0.65.1
 
 
 

1. APACHE Error: "Signaling Error: error already pending"

Hi all,

I am running an
E250
with
Solaris 2.7
Apache 1.3.12
Apache Jserv 1.05b

The error message I am getting is :
"Signaling Error" error already pending" I have search high and low and can
not find anything of use to help with this problem. This error is occuring
in the error_log file over and over, it is the only error in the file for
about 8 days...The server is idling at around 98% I would like to know if
anyone has seen this error and what would cause such a thing and how to
repair the problem....

Any help would be greatly appreciated. :)

Thanks,
Jeff

2. revise HD from /dev/fdX

3. Help! Errors, Errors, Errors!!!

4. Screensavers??

5. reboot error reboot error reboot error

6. unconfirmed sad news

7. tinyX gives "xinit: Unknown error (errno 0): Client error." error and dies

8. Zgv, Linux, and a Trident GUI 9660 card, and screen blanking.

9. gcc error: "elf error: file insn-attrtab.o: elf_strptr: Request error: no string table"

10. How can fix this error (hda error io error )

11. 1.2.8: boot error: hda: DRDY error: status=0x01 { Error }

12. (Review ID: 164268) HotSpot Virtual Machine Error, Internal Error; Error ID: 4F533F4C494E55580E43505

13. Install error on G3: "error unpacking archive: unknown error"