tiff and jpeg

tiff and jpeg

Post by And » Fri, 30 Oct 1998 04:00:00



Yesterday I tried to install hylafax port on my machine. It
requires tiff library, which in turn wants to have a jpeg
stuff. Now, the jpeg 6.<something>b went through without
problems, but then tiff34 didn't want to install. The
problem was (hm, still is) that tiff34 requires (I understood
it this way, at least) jpeg-7.<something>. What can/should
I do? Can somebody look into this please.

Thanx!

LPA

 
 
 

tiff and jpeg

Post by Martin Dieringe » Fri, 30 Oct 1998 04:00:00



Quote:> stuff. Now, the jpeg 6.<something>b went through without
> problems, but then tiff34 didn't want to install. The
> problem was (hm, still is) that tiff34 requires (I understood
> it this way, at least) jpeg-7.<something>. What can/should
> I do? Can somebody look into this please.

I yesterday installed both of these without problem
(from ports-current)
Martin

 
 
 

tiff and jpeg

Post by And » Fri, 30 Oct 1998 04:00:00




> > stuff. Now, the jpeg 6.<something>b went through without
> > problems, but then tiff34 didn't want to install. The
> > problem was (hm, still is) that tiff34 requires (I understood
> > it this way, at least) jpeg-7.<something>. What can/should
> > I do? Can somebody look into this please.

> I yesterday installed both of these without problem
> (from ports-current)

Hm, and which jpeg did you install? I did cvsup (ports-all) prior
installation though.

LPA

 
 
 

tiff and jpeg

Post by Kenneth Furg » Fri, 06 Nov 1998 04:00:00





> Hm, and which jpeg did you install? I did cvsup (ports-all) prior
> installation though.

I don't think that libtiff is particularly dependant on the .7 rev of
libjpg.  It's just that that's the latest version in the ports
collection.  Modify the libtiff port's Makefile and change the .7
dependancy to .6 and you'll probably be fine.

- K.C.

 
 
 

tiff and jpeg

Post by Mark Sling » Sat, 07 Nov 1998 04:00:00


Quote:>I don't think that libtiff is particularly dependant on the .7 rev of
>libjpg.  It's just that that's the latest version in the ports
>collection.  Modify the libtiff port's Makefile and change the .7
>dependancy to .6 and you'll probably be fine.

I just created a symbolic link and it seemed to work fine also.