XF86 and matrox g100

XF86 and matrox g100

Post by Sander Micaelse » Thu, 07 Jan 1999 04:00:00



Hi!

I decided today that i should try out freebsd - im used to linux and
stuff, but i wanted the taste of a real unix :)

My matrox g100 card will not up at all - tried to fix it the way i did
in linux - but that was wrong of me.

How do I do this correctly? - Ive installed all of the X packets under
the FreeBSD-3.0 install.

Would be glad for any help!

Sander.

 
 
 

XF86 and matrox g100

Post by Kenneth Furg » Thu, 07 Jan 1999 04:00:00



> Hi!

> I decided today that i should try out freebsd - im used to linux and
> stuff, but i wanted the taste of a real unix :)

> My matrox g100 card will not up at all - tried to fix it the way i did
> in linux - but that was wrong of me.

> How do I do this correctly? - Ive installed all of the X packets under
> the FreeBSD-3.0 install.

Which X server dir you install?  XFree86 is XFree86 whether it's linux
or FreeBSD.  Did you make sure to properly install and configure the
currect server for your card?

From the XFree86 FAQ:

Q.F5- Matrox chips

The 3.3.3 release includes a driver for the Matrox Millennium,
Millennium II, Mystique, Millennium G200, Mytique G200 and Productiva
G100 cards.  This driver is part of the XF86_SVGA server. Do not attempt
to use the XF98_MGA server unless you really do have one of the Japanese
PC98 architecture computers. If you want to know why, see the PC98
question.

- K.C.

 
 
 

XF86 and matrox g100

Post by Sander Micaelse » Sat, 09 Jan 1999 04:00:00




> > Hi!

> > I decided today that i should try out freebsd - im used to linux and
> > stuff, but i wanted the taste of a real unix :)

> > My matrox g100 card will not up at all - tried to fix it the way i did
> > in linux - but that was wrong of me.

> > How do I do this correctly? - Ive installed all of the X packets under
> > the FreeBSD-3.0 install.

> Which X server dir you install?  XFree86 is XFree86 whether it's linux
> or FreeBSD.  Did you make sure to properly install and configure the
> currect server for your card?

I used the xsuseconfig.tar that works on my linux system (slack 3.6)
tried to brandelf it - but that didnt solve anything :/
Then i installed 3.3.3 with the SVGA server that should support my card,
but neither xf86config or XF86Setup listed my card anyways. (I installed
the config and the SVGA server only.)

Thats why i was anxious to know if any of you have had any of my problems
:)
- Doesnt really bother me much - im not that often in X, but i like to have
my system properly configured :)

- Show quoted text -

Quote:

> From the XFree86 FAQ:

> Q.F5- Matrox chips

> The 3.3.3 release includes a driver for the Matrox Millennium,
> Millennium II, Mystique, Millennium G200, Mytique G200 and Productiva
> G100 cards.  This driver is part of the XF86_SVGA server. Do not attempt
> to use the XF98_MGA server unless you really do have one of the Japanese
> PC98 architecture computers. If you want to know why, see the PC98
> question.

> - K.C.

 
 
 

XF86 and matrox g100

Post by Kenneth Furg » Sat, 09 Jan 1999 04:00:00



> I used the xsuseconfig.tar that works on my linux system (slack 3.6)
> tried to brandelf it - but that didnt solve anything :/
> Then i installed 3.3.3 with the SVGA server that should support my card,
> but neither xf86config or XF86Setup listed my card anyways. (I installed
> the config and the SVGA server only.)

Here is a reference to someones supposedly working XF86Config file for a
Matrox card.  I don't own one of these so I cannot comment whether it is
indeed correct.

From:

http://beta5.dejanews.com/=fg/getdoc.xp?AN=397170074&CONTEXT=91580028...

# SaX autogenerated XF86Config file
# This file was generated from the SaX

# Date: Thu Oct  1 09:12:13 MEST 1998

Section "Files"
  RgbPath       "/usr/X11R6/lib/X11/rgb"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
  FontPath      "/usr/X11R6/lib/X11/fonts/Type1"
  FontPath      "/usr/X11R6/lib/X11/fonts/Speedo"
  FontPath      "/usr/X11R6/lib/X11/fonts/misc"
  FontPath      "/usr/X11R6/lib/X11/fonts/75dpi"
EndSection

Section "ServerFlags"
EndSection

Section "Keyboard"
  Protocol      "Standard"
  XkbRules      "xfree86"
  XkbModel      "microsoft"
  XkbLayout     "de"
  XkbVariant    "nodeadkeys"
EndSection

Section "Pointer"
  Protocol              "PS/2"
  Device                "/dev/psaux"
  SampleRate            0
  Emulate3Buttons
  Emulate3Timeout       200
  BaudRate              1200
EndSection

Section "Monitor"
  Identifier    "Primary Monitor"
  VendorName    "SAMSUNG"
  ModelName     "17GLSI"
  HorizSync     30-85
  VertRefresh   50-120
  Modeline "1024x768" 57.00 1024 1048 1104 1200 768 777 784 805
  Modeline "1024x768" 111.82 1024 1072 1192 1344 768 781 793 821
  Modeline "640x480" 25.00 640 648 672 792 480 493 497 535
  Modeline "640x480" 69.89 640 672 744 832 480 535 547 700
  Modeline "800x600" 34.00 800 816 848 904 600 609 614 637
  Modeline "800x600" 87.36 800 840 936 1040 600 625 637 700
EndSection

Section "Device"
  Identifier    "Primary Card"
  VendorName    "MATROX"
  BoardName     "MYSTIQUE"
  VideoRam      4096
  DacSpeed      170 170 170 170
EndSection

Section "Screen"
  Driver        "SVGA"
  Device        "Primary Card"
  Monitor       "Primary Monitor"
  DefaultColorDepth     24
  SubSection "Display"
    Depth       8
    Modes       "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth       16
    Modes       "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth       24
    Modes       "1024x768" "800x600" "640x480"
  EndSubSection
  SubSection "Display"
    Depth       32
    Modes       "1024x768" "800x600" "640x480"
  EndSubSection
EndSection

Best of luck.

- K.C.