PPP-Server Problem

PPP-Server Problem

Post by Erik Andersso » Sun, 14 Feb 1999 04:00:00



Hi,

I'm running FreeBSD Release 2.2.8 with pppd 2.3.5. I've set up my pppd
to
recive incomming calls, like an ISP. This is done with the follwing
configuration:

192.168.0.2 - bsd.splitvision.org - Thats the box I've tried to set up
!
(bsd.splitvision.org also act like a primary dns-server)

*****************
/etc/ppp/options
*****************

#!/bin/sh
crtscts
ms-dns 192.168.0.2
netmask 255.255.255.0
proxyarp
silent
192.168.0.2:192.168.0.55
domain splitvision.org
passive
persist
modem
login   #Checks pap-secrets, system password database
+pap   #require pap
-chap
-detach

********************
/etc/ppp/pap-secrets
********************

#user  server  secret
erikande  *  XXXXXXX

*************************************************
/etc/ppp/pppserv (used for fireing up the server)
*************************************************

#!/bin/sh
ps ax |grep pppd |grep -v grep
pid=`ps ax |grep pppd |grep -v grep|awk '{print $1;}'`
if [ "X${pid}" != "X" ] ; then
        echo 'killing pppd, PID=' ${pid}
        kill ${pid}
fi
ps ax |grep kermit |grep -v grep
pid=`ps ax |grep kermit |grep -v grep|awk '{print $1;}'`
if [ "X${pid}" != "X" ] ; then
        echo 'killing kermit, PID=' ${pid}
        kill -9 ${pid}
fi

# reset ppp interface
ifconfig ppp0 down
ifconfig ppp0 delete

# enable autoanswer mode
kermit -y /etc/ppp/kermit.ans

# run ppp
pppd /dev/ttyd0 115200

*********************************************************
/etc/ppp/kermit.ans (turns the modem into autoanswer mod)
*********************************************************

set line /dev/ttyd0
set speed 115200
set file type binary
set file names literal
set win 8
set rec pack 1024
set send pack 1024
set block 3
set term bytesize 8
set command bytesize 8
set flow none

pau 1
out +++
inp 5 OK
out ATH0\13
inp 5 OK
echo \13
out ATS0=1\13

inp 5 OK
echo \13
exit

When I try to connect to the ppp-server from a win98 box
with Micro$oft Dialup Networking the ppp-server answers and it doesn't
seem to
any problem. But the ppp-server refuses to accept my password despite
I've
put my username and password in the pap-secrets file. Here is where my
problem
occurs. When disable the following commands in /etc/ppp/options:

#login
#+pap
#-chap
#-detach

the dialup connects succesfully ! This means that I haven't found the
approporiate way for solving my authorizing problems. Have I missed
something
in the /etc/ppp/options file or have I mixed up the commands ? Is there
anyone
who can help me ? I've read trought the pppd manpage but it didn't make
me any
wiser !

Thanks in advance !


 
 
 

1. ppp-server problem

Hi !

I installed a linux-dialin-server and started a connection from a win95-pc.I
can get a connection and log in, but I am not able to ping the ra-server
from windows dos-box and vice versa and so I am not able to start a ftp to
the server to down- or upload files. I tried nearly everything to get rid of
the problem, but I can't see the point.

/etc/ppp/options :
lock
115200
crtscts
modem
debug

/etc/ppp/dialin :

silent
auth
+chap
-ipx-protocol
200.1.1.1:200.1.1.2
proxyarp
-defaultroute (tried it also without this)

/AutoPPP/ - - / usr/sbin/pppd file /etc/ppp/dialin
(in /etc/mgetty+sendfax/login.config)

The kernel has IP-Forwarding compiled in

I'm using S.U.S.E. 5.2

I tried to get help earlier in a different newsgroup, but got no help

Every help is welcome

Thanks in advance

Tim

2. X.25

3. PPP-SERVER Problems (routing??)

4. dh11 device driver for Ultrix 2.0

5. PPP server problem (LCP problem?)

6. bison and flex library sources

7. PPP Server problem or modem problem

8. G400 distortion on 2nd monitor

9. PPP server problem

10. ppp server problem

11. PPP Server problem

12. Dial up PPP Server problem

13. PPP server problems.