emacs 19.34 and FBSD 4.0

emacs 19.34 and FBSD 4.0

Post by Mikhail Kru » Sun, 09 Apr 2000 04:00:00



I may be missing the point, but isn't 20.6 the latest emacs version?

> When upgrading versions of FBSD, I usually upgrade the major apps I use to
> the latest distribution to make sure I am using latest libs and so on.
> I just upgraded to FBSD 4.0 and did this for emacs 19.34b.  Both the package
> and the port exhibit a weird behavior that prevents it from being used.
> When I start the editor, the status line at the bottom is broken across
> two lines and is essentially unusable any time I try to use it in a terminal
> (VT100) session.  The problem disappears when running emacs under X.

> The 3.4 version of the same editor is fine and does not exhibit this problem.

> Ideas anyone - TIA,
> --
> ------------------------------------------------------------------------------
> Tim Daneliuk


 
 
 

emacs 19.34 and FBSD 4.0

Post by Tim Daneliu » Mon, 10 Apr 2000 04:00:00


When upgrading versions of FBSD, I usually upgrade the major apps I use to
the latest distribution to make sure I am using latest libs and so on.
I just upgraded to FBSD 4.0 and did this for emacs 19.34b.  Both the package
and the port exhibit a weird behavior that prevents it from being used.
When I start the editor, the status line at the bottom is broken across
two lines and is essentially unusable any time I try to use it in a terminal
(VT100) session.  The problem disappears when running emacs under X.

The 3.4 version of the same editor is fine and does not exhibit this problem.

Ideas anyone - TIA,
--
------------------------------------------------------------------------------
Tim Daneliuk


 
 
 

emacs 19.34 and FBSD 4.0

Post by Tim Daneliu » Mon, 10 Apr 2000 04:00:00



> I may be missing the point, but isn't 20.6 the latest emacs version?


> > When upgrading versions of FBSD, I usually upgrade the major apps I use to
> > the latest distribution to make sure I am using latest libs and so on.
> > I just upgraded to FBSD 4.0 and did this for emacs 19.34b.  Both the package
> > and the port exhibit a weird behavior that prevents it from being used.
> > When I start the editor, the status line at the bottom is broken across
> > two lines and is essentially unusable any time I try to use it in a terminal
> > (VT100) session.  The problem disappears when running emacs under X.

> > The 3.4 version of the same editor is fine and does not exhibit this problem.

> > Ideas anyone - TIA,
> > --
> > ------------------------------------------------------------------------------
> > Tim Daneliuk


If I understand it correctly, 20.x and 19.x are both simultaneously
supported code branches. 'Not sure about the differences.  I should give
20.x a shot though, now that you mention it.  In the past I avoided it because
it was big and slow to load...
--
------------------------------------------------------------------------------
Tim Daneliuk

 
 
 

emacs 19.34 and FBSD 4.0

Post by Tim Daneliu » Mon, 10 Apr 2000 04:00:00



> I may be missing the point, but isn't 20.6 the latest emacs version?


> > When upgrading versions of FBSD, I usually upgrade the major apps I use to
> > the latest distribution to make sure I am using latest libs and so on.
> > I just upgraded to FBSD 4.0 and did this for emacs 19.34b.  Both the package
> > and the port exhibit a weird behavior that prevents it from being used.
> > When I start the editor, the status line at the bottom is broken across
> > two lines and is essentially unusable any time I try to use it in a terminal
> > (VT100) session.  The problem disappears when running emacs under X.

> > The 3.4 version of the same editor is fine and does not exhibit this problem.

> > Ideas anyone - TIA,
> > --
> > ------------------------------------------------------------------------------
> > Tim Daneliuk


'Good suggestion - 20.x works fine in both text and X modes...
--
------------------------------------------------------------------------------
Tim Daneliuk

 
 
 

emacs 19.34 and FBSD 4.0

Post by Rafal Grabowsk » Tue, 11 Apr 2000 04:00:00


Hello,

emacs 20.5, after compiling the source, does not work correctly under
4.0. It seems to be unusable without X. The bottom line is totally
corrupted. I installed the emacs-20.4 precompiled port and it works
fine. I have not tried emacs 20.6.

Thank you,
Rafal Grabowski



> > I may be missing the point, but isn't 20.6 the latest emacs version?


> > > When upgrading versions of FBSD, I usually upgrade the major apps I use to
> > > the latest distribution to make sure I am using latest libs and so on.
> > > I just upgraded to FBSD 4.0 and did this for emacs 19.34b.  Both the package
> > > and the port exhibit a weird behavior that prevents it from being used.
> > > When I start the editor, the status line at the bottom is broken across
> > > two lines and is essentially unusable any time I try to use it in a terminal
> > > (VT100) session.  The problem disappears when running emacs under X.

> > > The 3.4 version of the same editor is fine and does not exhibit this problem.

> > > Ideas anyone - TIA,
> > > --
> > > ------------------------------------------------------------------------------
> > > Tim Daneliuk

> 'Good suggestion - 20.x works fine in both text and X modes...
> --
> ------------------------------------------------------------------------------
> Tim Daneliuk


 
 
 

1. ssh/emacs 19.34 on Solaris/XF863.2A combo kills X server

Anyone else seen this?

Whenever I start emacs 19.34 on a Solaris 2.5 host using X port forwarding
with ssh 1.2.19, my X server (XFree SVGA 3.2A) dies with out of swap space.
The same combo, but the emacs on other platforms works Just Fine.

I am running FreeBSD 2.1.7

Jari

2. Kernel parameters for bootup

3. Emacs 19.34

4. Error seeking in /dev/kmem

5. RedHat's Emacs 19.34: h_errno_ problem

6. Raw I/O in unix.

7. A problem installing emacs 19.34

8. C Shell for NT

9. Emacs 19.34 on linux 2.2.15

10. networking problem with emacs 19.34, RH 4.2, AFS

11. emacs 19.34, gmalloc and hpux 10.20

12. compiling emacs 19.34 on glibc2 Linux machines

13. emacs 19.34, gmalloc and hpux 10.20