getty ?'s

getty ?'s

Post by Patrick Nat » Tue, 18 Mar 1997 04:00:00



I have a few modems set up on my FreeBSD 2.1.7 server. Everything works
fine except for getty does not know when the modems hang up. This
results in the next person to dial in,  to get a garbage screen (or
worse an open tty with the previous owner already loged in...)

I have already configured the gettytab with the to option but I can tell
if this is the right thing or not...

My ttys file looks like this

ttyd0   "/usr/libexec/getty std.38400"   dialup  on secure

My gettytab file looks like this

std.38400|38400-baud:\
        :to#25:np:sp#38400:

Any ideas ?

 
 
 

1. init: can't exec getty '/usr/libexec/getty' for port /dev/ttyv0:

In my new job, I have inherited a FreeBSD Box. To physically check out
some hardware I performed a Shutdown (can't remember the exact arguments
used now).

At restart, kernel processing appears to proceed without problems, until
the system somewhere during init, it apparently can't find getty. A
typical error report line looks like:
Jan 16 23:58:13 init: can't exec getty '/usr/libexec/getty' for port
/dev/ttyv0: No such file or directory
From this point, every 30 seconds the system constantly attempts to
execute getty.

And I can't get any response past this point. No keystrokes seem to do
anything, no tty devs of any kind seem to be in place. I can't RCMD from
another box anywhere.

I can reboot to a startup floppy (made with the boot.flp using fdimage),
but as the prblem seems to be a missing file (getty) I can;t get much
further.

I can get to the holographic tty4, but can't do much there either.

I can restart in single user mode, but that puts the system into
read-only mode and so I can't even see the /usr directory and files.

Any help appreciated......

2. Signals: sigaction, sigvec[tor]

3. Initiating application from 'getty', not 'login'?

4. Adaptec AHA-2940 troubles..

5. init: can't exec getty 'perl' for port /dev/cuaa0

6. Syntax check for bash scripts

7. init: can't exec getty 'none' ...

8. newbie asking about kill files

9. Getty disables 'shutdown -r now': a strange problem

10. Baud-sensing 'getty'

11. Slackware 2.0 getty vt100 emulation promblem, '3's at the end of line.