sbc

sbc

Post by Bria » Sat, 18 Mar 2000 04:00:00



I'm trying to get my sound card working under 4.0-release.  I have
read all the documentation that I can find, (snd, pcm, searching the
mailing list archives) I must be missing something.  

What I have done so far.
 - added sbc support into the kernel and recompiled
 - restarted with new kernel
 - dmesg shows that sbc0 is detected
 - created the snd0 devices

sbc0: <Creative SB AWE64> at port 0x220-0x22f, 0x330-0x331,0x388-0x38b
        irq5 drq 1,5 on isa0
sbc0: setting card to irq 5, drq 1, 5

I created the devices for snd0 (dsp0 and whatnot) with MAKEDEV snd0
However, whenever I try and use /dev/dsp0 or /dev/audio0 it fails to
work.  If I try to use it as a user, it says
        "cannot create /dev/audio0: no such device or address"
If  I try and use /dev/audio0 as root, it says
        "/dev/audio0: Device not configured."

Any help would be appriciated.

Brian Caswell
Sysadmin and stuff

 
 
 

sbc

Post by Donn Mille » Sat, 18 Mar 2000 04:00:00



Quote:> I'm trying to get my sound card working under 4.0-release.  I have
> read all the documentation that I can find, (snd, pcm, searching the
> mailing list archives) I must be missing something.  

> What I have done so far.
>  - added sbc support into the kernel and recompiled
>  - restarted with new kernel
>  - dmesg shows that sbc0 is detected
>  - created the snd0 devices

Did you also add

device pcm0

in your kernel config?  sbc is just the bridge driver that goes along with
pcm.  So, check out LINT for pcm options.  In my kernel config, for
example, I have

$ grep -E "pcm|sbc" /sys/i386/conf/CUSTOM
device          sbc0
device          pcm0

- Donn

 
 
 

sbc

Post by Pierre Carue » Mon, 20 Mar 2000 04:00:00



> I created the devices for snd0 (dsp0 and whatnot) with MAKEDEV snd0
> However, whenever I try and use /dev/dsp0 or /dev/audio0 it fails to
> work.  If I try to use it as a user, it says
>         "cannot create /dev/audio0: no such device or address"
> If  I try and use /dev/audio0 as root, it says
>         "/dev/audio0: Device not configured."

I have the same problem. The /dev/dsp is not created.
If anybody can qive me the major and minor device for it...

Pierre

--
=============================================================

R3/409 05 62 17 88 33
Supaero/Ecole Nat. Sup. de l'Aeronautique et de l'Espace
French National Aerospace School

 
 
 

1. pppoe, static ips & sbc business dsl

Hello-

I built a firewall/nat for a non-profit awhile back. Their DSL
connection was just basic SBC/Yahoo DSL. They are now talking about
upgrading to a SBC Business DSL package. I called SBC technical support
to ask if their business packages which comes with 5 static ips still
uses pppoe. The response I got from SBC is that some packages do and
some don't. If a particular package doesn't use pppoe, I'll have no
problems. I'm not sure where to begin if I get 5 static ips and have to
use pppoe. I have no way to test ahead of time. Anyone dealt with this
problem before? I guessing - would you edit /etc/ppp/options, remove
noipdefault and add local xx.xx.xx.xx. yy.yy.yy.yy etc.? Maybe
/etc/ppp/chaps-secret, /etc/ppp/paps-secret and edit the 4th column?

thanks,
Melvin

2. Squid does not cache after DNS server down

3. pppoe, ethernet, westell wirespeed, SBC, DSL, SuSE support

4. X windows display keeps breaking up.

5. start program on SBC after booting?

6. Debian 2.1 ipmasq security bug?

7. SBC embedded linux firewall

8. s/key auth and console

9. sbc like waysmall from gumstix

10. SBC DSL

11. SBC DSL and Redhat 8.0: Can ping, but that's it.

12. Looking for SH3 Based SBC

13. SBC Layout Diagrams