boot parition on cyl > 1024

boot parition on cyl > 1024

Post by Nymjol » Sun, 22 Aug 1999 04:00:00



Is there any way I can boot FreeBSD up on cylinder that is higher than 1024?
Or what could I do otherwise? I have approx. 1500 cyl. on a 13 GB drive.

Thanks in advance, Nymjolk.

 
 
 

boot parition on cyl > 1024

Post by Dan O'Conno » Sun, 22 Aug 1999 04:00:00


You don't specify how you have your drive laid out, or if you're using
multiple operating systems...but all you need to do is make sure your root
(/) partition is <1024 cyl.

If you're using the whole disk for FreeBSD, you won't have any problems.

--
--Dan O'Connor
[Remove '.nolunchmeat' when replying via e-mail]


>Is there any way I can boot FreeBSD up on cylinder that is higher than
1024?
>Or what could I do otherwise? I have approx. 1500 cyl. on a 13 GB drive.

>Thanks in advance, Nymjolk.


 
 
 

1. >1024 cyl, v1.1.18, boot problems

        Okay, The install went okay, now to the fun part:

        Using the boot disk that it made AFTER the install, it does'nt recognize the drive, I have a 1Gig (2099cyl,16hd,63sec)
and the error that comes up,

        [st506] unable to access drive /dev/hda
                (506 cyl, 64 hd, 16 sec]

        and some other errors that lead to the big extended registers display and halting.

        If I use the sbpcd boot disk, and enter

        boot: mount root=/dev/hda2 hd=2099,16,63

        It does go in, but gives me errors referencing that "hda2" is an unknown parameter. No big deal, I get in, but it tells me
the version of UMSDOS is v0.2, and the FTAPE is for UMSDOS v0.3.  Soooo, I recompile the whole kernel, and make a boot disk
according to the howto's and faqs, it gets to the point where I get the drive geometry errors.

        I've been told to add      append="hd=2099,16,63"   to the lilo stanza somewhere, but when I try to use the liloconfig
utility, it gives me an error when it tries to write to the floppy.

        Where exactly on the boot floppy can I tell it that the drive is   hd=2099,16,63   and have lilo work properly???

        Everything else works fine once I get in, this is the only problem I'm having now.  The docs, faqs, howto's have been
great, but I've yet to get this boot thing taken care of.

        Thanks

2. Solaris 2.2 & /vol

3. Can I boot Linux on SCSI partition > 1024 cyl?

4. Apache: send/read timeouts

5. hd params, >1024 cyl, boot disk problem

6. How to get X to load as fast as MS-Windows!!!

7. LiLo Question - How Boot > 1024 Cyl?

8. ASUS Motherboard P55TP4XE & P55TP4N

9. hd params, >1024 cyl, boot problems

10. Booting Linux when parition is higher than 1024 cylinder

11. cyl > 1024

12. lilo not working on my old 486 and disk geo > 1024 cyl

13. FDISK, cyl>1024, Disk Manager