DOS won't boot using LILO and Bootmanager

DOS won't boot using LILO and Bootmanager

Post by 25928-f » Sun, 16 Oct 1994 06:17:57



--
I setup my system to use OS/2 bootmanager to give me a menu to boot
Linux, DOS or OS/2 during boot-up.  It used to all work perfectly.
I had since then rebuilt the kernel and install it with LILO.  The
LILO configuration file has lines in the effect of
root=/dev/hda1
and
boot=/dev/had1

i.e. There is no reference to /dev/hda2 (the DOS partition) nor
/dev/hda (the whole disk).  The install was successful and I can
still use bootmanager to boot up OS/2 and Linux.  But DOS won't come
up anymore!!!  I don't understand why.  I can boot up DOS from a
floppy and it will use drive C: (the DOS boot disk).  I did a
fdisk /mbr but it doesn't help (how do I tell it which disk to
restore MBR on?)  I did "sys c:" but that doesn't help.
Everythin I select DOS from the boot manager, I get a blank screen.
I tried using the DOS fdisk to change the active partition from
bootmanager to drive C: but it still won't boot up.  Please help me.
Thanks.

--------------------------------------------------------------------------
Lawrence Fan                                                (908) 699-8051
Bellcore                    444 Hoes Lane, RRC-1D270, Piscataway, NJ 08854

 
 
 

1. Lilo boot won't allow DOS to boot

I just upgraded my kernel to v1.0 from 0.99.14.

Did the usual make config,
Did the usual make config,
              make dep
              make clean
              make

I followed the v1.0 kernel installation instructions and now I cannot load
DOS when I turn on my computer.  I do not know what all the commands do
(pretty dangerous :)) but when I rdev it says => /dev/hda2.

 /dev/hda1 = DOS partition
 /dev/hda2 = Linux fs
 /dev/hda2 = Linux fs
 /dev/hda2 = linux swap.

I cannot seem to change the filesystem back to dos, even when I boot dos
from my a: drive and use fdisk.  I really do not want to dump the Linux fs
and start from scratch.

I have all the HOW documents but maybe I have missed the right one.
Can anybody tell me what's up?

Robert Newton

2. perl: warning: Setting locale failed. ???

3. Using Lilo to Boot different flavors of DOS/Win

4. vi error filtering text thru command

5. HELP!!! Lilo won't boot dos

6. gnu gcc comipler binaries for solaris 2.5?

7. *** lilo won't boot win' 95 ***

8. ANNOUNCE: BETA: tkgoodstuff4.1b4 button bar and utility suite

9. DOS Partition Won't Boot From LILO

10. Help: DOS Partition Won't Boot from LILO

11. LILO won't boot DOS

12. lilo problem, dos partition won't boot, HELP!

13. LILO won't boot dos on secondary ide /dev/hdc