Always IN-2000 scsi hd controller card probs -w- LILO/BOOT in Linux

Always IN-2000 scsi hd controller card probs -w- LILO/BOOT in Linux

Post by John Q. Publ » Sat, 25 Jun 1994 05:08:03



okay, I've had this problem for quite awhile. I'm using an in-2000 scsi
controller card for my /dev/sda harddisk and my bootable (linux) partition
is /dev/sda2. the only way i can run linux off my harddisk is if i boot
with the in-2000 boot kernel disk that i ftped from cdrom.com and i have
to type mount root=/dev/sda2 at the boot: prompt.

when i try booting from a bootable disk or LILO (on my hda because it just
won't work on my sda) the following appears:

Loading Linux...
Uncompressing Linux.....done
Now booting kernel
Console: color EGA+ 80x25, 8 virtual consoles
serial driver version 3.99a with no serial options enabled
tty00 at 0x03f8 (irq=4) is a 16450
tty01 at 0x02f8 (irq=3) is a 16450
lpt1 exists using polling driver
ftape: allocated 3 buffers alligned at: 001f0000
Calibrating delay loop.. ok - 2.01 BogoMips
failed
scsi: 0 hosts
scsi: detected 0 scsi disks detected 0 tape drives (and someother things)...
Memory --- (display scrolled by too fast)
Partition check:
  hda: hda1
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (1)
MINIX-fs: unable to read superblock
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (1)
EXT2-fs: unable to read superblock
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
XIA-fs: read super_block failed (inode.c 74)
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
MSDOS bread failed
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (32)
isofs_read_super: bread failed, dev 0x802 iso_blknum 16
SCSI disk request error: invalid device.
VFS: Wrong blocksize on device 8/2
VFS: Wrong blocksize on device 8/2
VFS: Wrong blocksize on device 8/2
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
HPFS: map_sector: read error
kernel panic: VFS: Unable to mount root

hope this helps someone tell me EXACTLY what to do to fix this ever annoying
(and if i understand correctly) global problem for all in-2000 scsi users.

oh and by the way: Houston Rockets #1! yeah! :-)
IN YOUR ARROGANT, SNOTTY FACE NEW YORK!

(just HAD to say that. hope it doesnt impede my getting help)

 
 
 

1. Always IN-2000 SCSI card LILO/BOOT problem

Newsgroups: comp.os.linux.help
Subject: Always IN-2000 scsi hd controller card probs -w- LILO/BOOT in Linux
Summary:
Expires:
Sender:
Followup-To:
Distribution: world
Organization: Cypher Technologies
Keywords:
Cc:

okay, I've had this problem for quite awhile. I'm using an in-2000 scsi
controller card for my /dev/sda harddisk and my bootable (linux) partition
is /dev/sda2. the only way i can run linux off my harddisk is if i boot
with the in-2000 boot kernel disk that i ftped from cdrom.com and i have
to type mount root=/dev/sda2 at the boot: prompt.

when i try booting from a bootable disk or LILO (on my hda because it just
won't work on my sda) the following appears:

Loading Linux...
Uncompressing Linux.....done
Now booting kernel
Console: color EGA+ 80x25, 8 virtual consoles
serial driver version 3.99a with no serial options enabled
tty00 at 0x03f8 (irq=4) is a 16450
tty01 at 0x02f8 (irq=3) is a 16450
lpt1 exists using polling driver
ftape: allocated 3 buffers alligned at: 001f0000
Calibrating delay loop.. ok - 2.01 BogoMips
failed
scsi: 0 hosts
scsi: detected 0 scsi disks detected 0 tape drives (and someother things)...
Memory --- (display scrolled by too fast)
Partition check:
  hda: hda1
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (1)
MINIX-fs: unable to read superblock
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (1)
EXT2-fs: unable to read superblock
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
XIA-fs: read super_block failed (inode.c 74)
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
MSDOS bread failed
SCSI disk request error: invalid device
ll_rw_block: Trying to read nonexistent block-device 0802 (32)
isofs_read_super: bread failed, dev 0x802 iso_blknum 16
SCSI disk request error: invalid device.
VFS: Wrong blocksize on device 8/2
VFS: Wrong blocksize on device 8/2
VFS: Wrong blocksize on device 8/2
ll_rw_block: Trying to read nonexistent block-device 0802 (0)
HPFS: map_sector: read error
kernel panic: VFS: Unable to mount root

hope this helps someone tell me EXACTLY what to do to fix this ever annoying
(and if i understand correctly) global problem for all in-2000 scsi users.

oh and by the way: Houston Rockets #1! yeah! :-)
IN YOUR ARROGANT, SNOTTY FACE NEW YORK!

(just HAD to say that. hope it doesnt impede my getting help)

2. iptables dmz host similar to linksys, etc?

3. Always IN-2000 SCSI Controller problem

4. More bash 2.04 completions

5. Always IN-2000 SCSI card

6. FTP - Server ? which one

7. Always IN-2000 SCSI Card

8. increase file descriptors limit

9. IN-2000 SCSI ALWAYS Slackware Boot Disk Not Working

10. Setup information for Always Technology IN-2000 SCSI host

11. Always IN-2000 SCSI problems

12. Always Tech IN-2000 SCSI problems

13. Always IN-2000 SCSI host