Login on virtual terminals fails to supress password entry?

Login on virtual terminals fails to supress password entry?

Post by loma » Fri, 27 Jun 1997 04:00:00



Hi there,

I have the following problem:

When I log in from the console (/dev/tty1) everything works fine. If I
switch to a virtual terminal (dev/tty2-ttyn) then getty accepts the
username and correctly starts teh login programme for the password.
However the keystrokes for the password are not suppressed when the
user enters the password and the system hangs once enter is pushed. It
hangs for about a minute before returing login incorrect and shows the
username prompt.

I think the problem is with the login programme and not getty as it
fails at the password prompt. Any ideas/help would be appreciated.

thanking you in advance

Lomax

 
 
 

Login on virtual terminals fails to supress password entry?

Post by Justin Pelletie » Sun, 29 Jun 1997 04:00:00



> Hi there,

> I have the following problem:

> When I log in from the console (/dev/tty1) everything works fine. If I
> switch to a virtual terminal (dev/tty2-ttyn) then getty accepts the
> username and correctly starts teh login programme for the password.
> However the keystrokes for the password are not suppressed when the
> user enters the password and the system hangs once enter is pushed. It
> hangs for about a minute before returing login incorrect and shows the
> username prompt.

> I think the problem is with the login programme and not getty as it
> fails at the password prompt. Any ideas/help would be appreciated.

> thanking you in advance

> Lomax

Check in /etc/inittab for the difference in parameters between the getty
for /dev/tty1 and the others.

Justin Pelletier
JP Programmation
Montreal, Canada


 
 
 

1. Login on virtual terminals fails to supress password entry?

Hi there,

I have the following problem:

When I log in from the console (/dev/tty1) everything works fine. If I
switch to a virtual terminal (dev/tty2-ttyn) then getty accepts the
username and correctly starts teh login programme for the password.
However the keystrokes for the password are not suppressed when the
user enters the password and the system hangs once enter is pushed. It
hangs for about a minute before returing login incorrect and shows the
username prompt.

I think the problem is with the login programme and not getty as it
fails at the password prompt. Any ideas/help would be appreciated.

thanking you in advance

Lomax

2. compiling freebsd kernel from linux

3. Solaris Telnet, how to suppress password entry?

4. psaux mouse problem

5. UUCP fails with message Cannot rewrite protected password entry

6. Patch(?): linux-2.4.3-pre6/mm/vmalloc.c could return with init_mm.page_table_lock held

7. slow login after password entry

8. Permanantly loged in user

9. Virtual Terminals go away after login to KDE

10. ioctl call fails when not on virtual terminal - help!

11. Virtual Terminals go away after login to KDE

12. pop3 login fails on virtual host imap mail server