pl14 and ftape0.98 problems. Can you help?

pl14 and ftape0.98 problems. Can you help?

Post by R Yeun » Sun, 19 Dec 1993 05:04:43



Hi,

        I just got pl14 and compiled it.  I applied the module patches, and
that works fine.  I compiled the ftape driver, and it seemed to compile OK.  
However, when I try to load the module, it gives me the following:

_sys_sgetmask undefined
_sys_ssetmask undefined

Am I missing something?  I have GCC 2.4.5, and libs 4.4.1.  I got pl14 and
the ftape stuff off tsx-11.mit.edu.

Any advice would be greatly appreciated!  Thanks!

 _I_______________________________________________________________________I_



|   |   EE student at the                                               |   |
|   |   University of Illinois    CompuServe: 70700,1011                |   |
|   |   at Urbana-Champaign                                             |   |
(___)-------------------------------------------------------------------(___)
  I                                                                       I

 
 
 

pl14 and ftape0.98 problems. Can you help?

Post by Terry Carl » Tue, 21 Dec 1993 02:23:36


: Hi,

:       I just got pl14 and compiled it.  I applied the module patches, and
: that works fine.  I compiled the ftape driver, and it seemed to compile OK.  
: However, when I try to load the module, it gives me the following:

: _sys_sgetmask undefined
: _sys_ssetmask undefined

: Am I missing something?  I have GCC 2.4.5, and libs 4.4.1.  I got pl14 and
: the ftape stuff off tsx-11.mit.edu.

: Any advice would be greatly appreciated!  Thanks!

The following lines were left out of the kernel patch.
In linux/kernel/ksym.S find:
#ifdef CONFIG_FTAPE
#
# The next labels are needed for ftape driver.
#
  _ftape_big_buffer
  _xtime
  _do_floppy
  _tick

  _sys_sgetmask
  _sys_ssetmask
^^^^^^^^^^^^^^^^^^   Add the two above lines and remake your kernel
#endif
--
Terry Carlin


 
 
 

1. PCI UltraSCSI card REQUIRES Sol 2.6 HW 5/98 (not 3/98) ?

Hi--

I recently ordered the (new?, inexpensive) "PCI UltraSCSI single-ended
host adapter [single-channel model]" from Sun for our Ultra 5-- BUT I
am dismayed to find, now that it has arrived, that according to its
manual it will require "Solaris 2.6 5/98."  What we have is Solaris 2.6
Hardware 3/98 (with kernel patch 105181-09)-- i.e., 3/98 rather than
5/98.

Basically I am wondering, what are the odds that we may be able to get
away with our HW 3/98 release (plus kernel patch) & this SCSI card, &
not have to reinstall the whole OS ?  (And what are the odds that we
might damage something by trying ?)

I see from Sunsolve that there is a "kernel/misc/scsi patch"
(106173-03)-- might that be helpful in our situation ?  That one is NOT
yet applied here.

Thanks very much for any insights or pointers,

Dan Smith

2. Network Time Protocol

3. Solaris 2.6 3/98 vs 5/98?

4. Help: Sendmail 8.8.5 on Slackware 3.2.0

5. Differences between Solaris 2.6 March 98 and May 98

6. USB on a Lombard with R4?

7. how to create 98 boot image in linux thro' 98 backup

8. HELP! My Logitech mouse hangs my X server!

9. Patched 2.6 3/98 and 2.6 5/98 the same?

10. Windows 98 crashes at COMDEX '98

11. 3/98 == 5/98 ?

12. My networking works 98% correctly but has an odd problem, Please help

13. XFree85 3.3.3, RH5.1, and ATI Xpert 98 config problems - help pls !!!