Problem in using PAS16 + Chinon cd-rom CDS-535

Problem in using PAS16 + Chinon cd-rom CDS-535

Post by Galen Sei » Tue, 12 Apr 1994 15:26:46




Quote:>HI,
>I have a great trouble in using PAS16 card with Chinon CD-Rom CDS535 (internal).
>The following is the actual output (I retype it) when I using
>Slackware 1.2 SCSI bootdisk (3.5").

                <more stuff deleted>

Quote:>scsi0: Pro Audio Spectrum - 16 SCSI
>scsi: 1 hosts
>  Vender:CHINON                     Model:CD-ROM    CDS-535                 Rev:Q20
>  Type:CD-ROM                                       ANSI SCSI
>Detected scsi CD-ROM sr0 at SCSI0, id0, lun0
>scsi0 : reseting for second half of retries

    system hangs here

 The Chinon drive is your problem.  Apparently it does not like being polled
 for multiple logical units.

 While filling out the recent hardware survey in linux.announce, I realized
 I hadn't sent this fix to anyone.  My apologies.

 When I would try to boot the Slackware 1.1.1 boot floppy my system would
 hang just after printing a message about resetting for second half retries.
 I finally got my system up by borrowing a friend's Toshiba CD-ROM, installing,
 and then building a kernel with the Chinon drive added to the blacklist.

 My system is a 486-66 with an ultrastor 34F and a Conner CP30540 drive.

 >1.16) CD ROM questions:
 >
 >Manufacturer:Chinon
 >Model:CDS-535
 >Type [IDE/SCSI]:SCSI
 >ALPHA? [Y/N]:
 >Comments:
 I had major problems getting this drive to work.  My solution was to add the
 following line to the blacklist array in drivers/scsi/scsi.c
    {"CHINON","CD-ROM CDS-535","Q14"},
 This was still necessary after upgrading the firmware to rev Q20.

Galen Seitz

 
 
 

Problem in using PAS16 + Chinon cd-rom CDS-535

Post by Chung Hoi Kw » Tue, 12 Apr 1994 08:51:44


HI,
I have a great trouble in using PAS16 card with Chinon CD-Rom CDS535 (internal).
The following is the actual output (I retype it) when I using
Slackware 1.2 SCSI bootdisk (3.5").

                <stuff deleted>

aha152x: Probling: BIOS test : failed
scsi0: at 0x0388 irq 10 options CAN_QUEUE CMD_Per_Lun = 2 released =1 generic
options AUTOPROEE_IRQ AUTO SENSE PSEUDO DMA generic released=4
scsi0: Pro Audio Spectrum - 16 SCSI
scsi: 1 hosts
  Vender:CHINON                 Model:CD-ROM    CDS-535                 Rev:Q20
  Type:CD-ROM                                   ANSI SCSI
Detected scsi CD-ROM sr0 at SCSI0, id0, lun0
scsi0 : reseting for second half of retries

After this, the light of my 3.5" FD is on and the drive is keep running and  
running.  My machine is hang!!!!!  Keyboard also locked!
I totally don't know what is going on.  My cd-rom both works fine under DOS
and Windows.  

System config:  Gateway2000 486/33C ISA (11/91 product)
                20 MB RAM
                1 MB Video card using Cirrus Logic CL-GD542X
                Pro Audio Spectrum 16  (I don't know the revision, 11/92 )      
                WD 120MB HD + Conner 170MB HD
                Chinon cd-rom CDS-535


Thanks in advance!

Wellwin Kwok