Taylor UUCP <-> VAX/VMS UUCP problems

Taylor UUCP <-> VAX/VMS UUCP problems

Post by Hugh Fras » Tue, 20 Sep 1994 23:50:35



I'm trying to get my Slackware Linux box to talk to a VAX/VMS system running
DECUS UUCP (which daily talks successfully to a Sun workstation for its
newsfeeds. Connection is made from the VMS system, and are made successfully,
but partway through transmitting a compressed new batch, the connection is
dropped because of too man "g" protocol errors. I've turned on detailed
debugging, and it appears packets are being sent out-of-sequence from the VMS
system. The exchange looks like this:

newsmgr dofasco (9/18-13:33:09,2426,0) DEBUG: fgprocess_data: Got packet 2
newsmgr dofasco (9/18-13:33:09,2426,0) DEBUG: fgsend_control: Sending control RR 2
newsmgr dofasco (9/18-13:33:09,2426,0) DEBUG: fgwait_for_packet: Need 5 bytes
newsmgr dofasco (9/18-13:33:10,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:11,2426,0) DEBUG: fgprocess_data: Got packet 3
newsmgr dofasco (9/18-13:33:11,2426,0) DEBUG: fgsend_control: Sending control RR 3
newsmgr dofasco (9/18-13:33:11,2426,0) DEBUG: fgwait_for_packet: Need 6 bytes
newsmgr dofasco (9/18-13:33:12,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:13,2426,0) DEBUG: fgprocess_data: Got packet 4
newsmgr dofasco (9/18-13:33:13,2426,0) DEBUG: fgsend_control: Sending control RR 4
newsmgr dofasco (9/18-13:33:13,2426,0) DEBUG: fgwait_for_packet: Need 6 bytes
newsmgr dofasco (9/18-13:33:13,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:15,2426,0) DEBUG: fgprocess_data: Got packet 5
newsmgr dofasco (9/18-13:33:15,2426,0) DEBUG: fgsend_control: Sending control RR 5
newsmgr dofasco (9/18-13:33:15,2426,0) DEBUG: fgwait_for_packet: Need 6 bytes
newsmgr dofasco (9/18-13:33:15,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:17,2426,0) DEBUG: fgprocess_data: Got packet 3; expected 6
newsmgr dofasco (9/18-13:33:17,2426,0) DEBUG: fgwait_for_packet: Need 6 bytes
newsmgr dofasco (9/18-13:33:17,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:19,2426,0) DEBUG: fgprocess_data: Got packet 4; expected 6
newsmgr dofasco (9/18-13:33:19,2426,0) DEBUG: fgwait_for_packet: Need 6 bytes
newsmgr dofasco (9/18-13:33:19,2426,0) DEBUG: fgwait_for_packet: Need 64 bytes
newsmgr dofasco (9/18-13:33:21,2426,0) DEBUG: fgprocess_data: Got packet 5; expected 6
newsmgr dofasco (9/18-13:33:21,2426,0) ERROR: Too many 'g' protocol errors
uucp dofasco (9/18-13:33:21,2426,0) DEBUG: fgsend_control: Sending control CLOSE 0
uucp dofasco (9/18-13:33:21,2426,0) DEBUG: fgsend_control: Sending control CLOSE 0
uucp dofasco (9/18-13:33:21,2426,0) Protocol 'g' packets: sent 1, resent 0, received 381
uucp dofasco (9/18-13:33:21,2426,0) Errors: header 0, checksum 0, order 139, remote rejects 0

The VMS<->Sun connection is via a Telebit T1000 modem with UUCP spoofing
turned on. The Linux system has a USR 14.4 Sportster, but since both ends lack
a common high-speed or error-correcting protocol, the connection is made at
2400 baud. Suspecting that timing might be an issue, I've relaxed the UUCP
timeouts on the Linux system, and changed the inittab entry to work at 2400
baud instead of 38400 (thinking that maybe UUCP adjusts timing based upon the
baud rate of the connection). Nothing seems to help.

Suggestions? By the way, small text mail messages are sent from the VMS system
to Linux successfully. Since there are several news batches in the queue ahead
of mail messages from the VMS to Linux system, I've not been able to check the
reverse path yet.

 
 
 

1. Solaris UUCP <-> Taylor UUCP

I am trying to get Solaris 2.3 UUCP to work with Taylor UUCP 1.04. For
a little while it received OK but couldn't send, but now nothing
works. This is what it does: I start uucico in my Linux machine, it
calls the Sparc, logs in successfully, negotiates protocol OK (G, 64
byte packets and 7 windows) and then hangs. The Linux uucico keeps
resending until it times out. The Sparc uucico reports nothing special
to the logs, it just says timed out. tip and cu work OK between these
machines. I suspect it is a parity problem: Linux UUCP is 8 bit, no
parity, and Sparc is even parity. Also, in the serial communications
FAQ for Solaris, the writer said there is a bug in Solaris hardware
flow control so that it only works in one direction. So, should I use
crtscts or what? The Sparc modem is 9600 bps Multitech and the Linux
modem is 1200 bps Nokia.

I have a well-working UUCP connection between two Linux machines with
Taylor UUCP in both of them. I feel tempted to install Taylor UUCP in
the Sparc. Is this doable and feasible? Taylor UUCP seems a lot nicer
than the Solaris version.

Janne Himanka
--

she said, "but /I've/ heard nonsense,   %%%% http://www.oulu.fi/jh.html
compared with which that would be   %%%%%%%% Dept. of Library & Inf. Sc.
as sensible as a dictionary!"   %%%%%%%%%%%% Oulu University, Finland

2. Browser problems

3. Taylor UUCP - UUCP using HDB config

4. cdrom-stress

5. <><><> MOUNTING EXTENDED PARTITION <><><>

6. USR 3070 pnp configuration

7. Wanted: <><><> Unix Specialist <><><>

8. XloadRunner on AIX 4.2?

9. LILO help <><><><><><>

10. packet-radio <=> internet <=> uucp mail gateway questions.

11. uucp for VAX/VMS

12. UUCP --> Internet --> UUCP connection

13. taylor uucp 1.04 - akl - "taylor config / performance" release